summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-08-27 13:36:18 -0400
committerEli Schwartz2018-08-27 13:36:18 -0400
commit92e3276ff55f35a3d59dc773704e3e9f62e9f549 (patch)
treeedfabde2fbe08a090dc2a93eb4310972b8ea312d
parent555261e54cf5e0ce1650dd279bdfd0fc868c8c30 (diff)
downloadaur-92e3276ff55f35a3d59dc773704e3e9f62e9f549.tar.gz
upgpkg: glibc-git 2.28.r97.g99ea93ca31-1
properly fix the breaking commit after discussion with commit author; fix is being discussed on libc-alpha
-rw-r--r--.SRCINFO4
-rw-r--r--0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch60
-rw-r--r--PKGBUILD8
3 files changed, 68 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a549588f42d7..428ee5e7ebf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glibc-git
pkgdesc = GNU C Library
- pkgver = 2.28.r89.g60bcac09c0
+ pkgver = 2.28.r97.g99ea93ca31
pkgrel = 1
url = https://www.gnu.org/software/libc/
install = glibc-git.install
@@ -22,10 +22,12 @@ pkgbase = glibc-git
source = git+https://sourceware.org/git/glibc.git
source = locale-gen
source = 0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+ source = 0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch
source = bz20338.patch
sha256sums = SKIP
sha256sums = 05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de
sha256sums = 3b764c4e5658486d1f9e98a36043eb51705c4eebc9abe3f9edc5049dd5dcdc47
+ sha256sums = a1f8f7dbe9cbaf81df21a7134b80beea7bedeecd37777c6d2f78f84d0f0548e0
sha256sums = 959d4f41edd004bddd9091c4d8c8c3aa07d79a04bfdb89d59f9f26fe5a74d32a
pkgname = glibc-git
diff --git a/0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch b/0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch
new file mode 100644
index 000000000000..d258b551d0be
--- /dev/null
+++ b/0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch
@@ -0,0 +1,60 @@
+From 1a82d7c95dda6efefeb1f3af57fbb20063b5339e Mon Sep 17 00:00:00 2001
+From: DJ Delorie <dj at redhat dot com>
+Date: Mon, 27 Aug 2018 02:39:05 -0400
+Subject: [PATCH] test-in-container: fix Arch Linux build-programs bug?
+
+Turns out Arch Linux uses the build-programs variable to build
+different parts of glibc with different flags; but setting
+build-programs to "no" also disables the default rules for programs,
+leading to makefile-related errors elsewhere.
+
+Since the "others:" target already depends on $(others) (or not) depending
+on build-programs - see :
+
+ifeq ($(build-programs),yes)
+others: $(addprefix $(objpfx),$(others) $(sysdep-others) $(extra-objs))
+else
+others: $(addprefix $(objpfx),$(extra-objs))
+endif
+
+Setting $(others) is sufficient, and dependencies on others: are
+redundant - or in this case, problematic.
+
+Is my understanding and description accurate?
+
+Tested via plain builds/tests with and without build-programs=no, plus
+build-many-glibcs for targets x86_64-linux-gnu, i686-gnu, and
+ia64-linux-gnu.
+
+Ok to install?
+
+ * support/Makefile (others): Don't list programs explicitly as
+ a dependency of "others".
+---
+ support/Makefile | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/support/Makefile b/support/Makefile
+index 0ed00212cb..b528f538a6 100644
+--- a/support/Makefile
++++ b/support/Makefile
+@@ -168,16 +168,6 @@ LINKS_DSO_PROGRAM = links-dso-program
+ LDLIBS-links-dso-program = -lstdc++ -lgcc -lgcc_s $(libunwind)
+ endif
+
+-others: \
+- $(objpfx)test-container \
+- $(objpfx)shell-container \
+- $(objpfx)echo-container \
+- $(objpfx)true-container \
+- $(objpfx)$(LINKS_DSO_PROGRAM)
+-
+-ifeq ($(build-programs),yes)
+-endif
+-
+ LDLIBS-test-container = $(libsupport)
+
+ others += test-container
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 03157867919e..287997910de0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.28.r89.g60bcac09c0
+pkgver=2.28.r97.g99ea93ca31
pkgrel=1
pkgdesc='GNU C Library'
arch=('i686' 'x86_64')
@@ -23,10 +23,12 @@ install='glibc-git.install'
source=('git+https://sourceware.org/git/glibc.git'
'locale-gen'
'0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch'
+ '0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch'
'bz20338.patch')
sha256sums=('SKIP'
'05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de'
'3b764c4e5658486d1f9e98a36043eb51705c4eebc9abe3f9edc5049dd5dcdc47'
+ 'a1f8f7dbe9cbaf81df21a7134b80beea7bedeecd37777c6d2f78f84d0f0548e0'
'959d4f41edd004bddd9091c4d8c8c3aa07d79a04bfdb89d59f9f26fe5a74d32a')
pkgver() {
@@ -47,9 +49,9 @@ prepare() {
# https://github.com/electron/electron/issues/13972#issuecomment-411532741
patch -p1 -i ../0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
- # revert untested patch that breaks the build.
+ # fix build error, turns out to be lack of testing for build-programs=no in configparms
# make[2]: *** No rule to make target '/build/glibc-git/src/build/support/links-dso-program', needed by 'others'. Stop.
- git show 561b0bec4448f0302cb4915bf67c919bde4a1c57 -- ':!ChangeLog' | git apply --verbose --reverse --index
+ patch -p1 -i ../0001-test-in-container-fix-Arch-Linux-build-programs-bug.patch
}
build() {