summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-02-15 23:22:43 -0500
committerEli Schwartz2020-02-15 23:22:43 -0500
commitaa7b3636c0f6b85c2bc684877562b18d8873874f (patch)
treeb6da0992493c4c34f24e489f6afd3e3e72802e8c
parentd81aa1934561c04ca717793fc5ce19a93c9eee24 (diff)
downloadaur-aa7b3636c0f6b85c2bc684877562b18d8873874f.tar.gz
upgpkg: glibc-git 2.31.r148.gca843defbc-1
rebase patches to apply cleanly
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch32
-rw-r--r--PKGBUILD4
3 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5e0466c685f..8992e79eea3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glibc-git
pkgdesc = GNU C Library
- pkgver = 2.30.r129.gd7a568af55
+ pkgver = 2.31.r148.gca843defbc
pkgrel = 1
url = https://www.gnu.org/software/libc/
install = glibc-git.install
@@ -15,7 +15,7 @@ pkgbase = glibc-git
depends = tzdata
depends = filesystem
optdepends = gd: graph image generation with memusage
- provides = glibc=2.30
+ provides = glibc=2.31
conflicts = glibc
options = staticlibs
backup = etc/gai.conf
@@ -26,7 +26,7 @@ pkgbase = glibc-git
source = bz20338.patch
sha256sums = SKIP
sha256sums = 05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de
- sha256sums = 1f54579c1d8dd0abdb05e20516272753164c9e77e233da1ad2e11da96ed20ba1
+ sha256sums = 6a3de26cec7b5b3e05090e85e970705454d9d749dcd4a2e1d35bee11d4e3637b
sha256sums = 7ff38c08e51c4a0a3d7fd2712cf435f700bef078fb8f4e7566424ae3d1754bab
pkgname = glibc-git
diff --git a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
index 8031f63a9518..6134cf3df022 100644
--- a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+++ b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
@@ -1,4 +1,4 @@
-From 962eb3d555c0d95d704922032c4750b468818e4e Mon Sep 17 00:00:00 2001
+From 5daaa10c03afc2180b698e0751bbc2b4abc313f0 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Fri, 28 Sep 2018 05:19:46 +0000
Subject: [PATCH] Revert "elf: Correct absolute (SHN_ABS) symbol run-time
@@ -18,19 +18,19 @@ This reverts commit e7feec374c635b6a29d65c39ae5e1855528fed39.
delete mode 100644 elf/tst-absolute-sym.c
diff --git a/elf/Makefile b/elf/Makefile
-index 8f962991a3..98d531ae3a 100644
+index 632a4d8b0f..2a824e3c64 100644
--- a/elf/Makefile
+++ b/elf/Makefile
-@@ -190,7 +190,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
+@@ -197,7 +197,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
tst-tlsalign tst-tlsalign-extern tst-nodelete-opened \
tst-nodelete2 tst-audit11 tst-audit12 tst-dlsym-error tst-noload \
tst-latepthread tst-tls-manydynamic tst-nodelete-dlclose \
- tst-debug1 tst-main1 tst-absolute-sym tst-absolute-zero tst-big-note \
+ tst-debug1 tst-main1 tst-absolute-zero tst-big-note \
tst-unwind-ctor tst-unwind-main tst-audit13 \
- tst-sonamemove-link tst-sonamemove-dlopen tst-dlopen-aout
- # reldep9
-@@ -276,7 +276,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
+ tst-sonamemove-link tst-sonamemove-dlopen tst-dlopen-tlsmodid \
+ tst-dlopen-self tst-auditmany tst-initfinilazyfail tst-dlopenfail \
+@@ -303,7 +303,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
tst-audit12mod1 tst-audit12mod2 tst-audit12mod3 tst-auditmod12 \
tst-latepthreadmod $(tst-tls-many-dynamic-modules) \
tst-nodelete-dlclose-dso tst-nodelete-dlclose-plugin \
@@ -38,9 +38,9 @@ index 8f962991a3..98d531ae3a 100644
+ tst-main1mod tst-libc_dlvsym-dso \
tst-absolute-zero-lib tst-big-note-lib tst-unwind-ctor-lib \
tst-audit13mod1 tst-sonamemove-linkmod1 \
- tst-sonamemove-runmod1 tst-sonamemove-runmod2
+ tst-sonamemove-runmod1 tst-sonamemove-runmod2 \
diff --git a/elf/dl-addr.c b/elf/dl-addr.c
-index e48795871b..482704e77f 100644
+index 693cfd2a62..4458a521f4 100644
--- a/elf/dl-addr.c
+++ b/elf/dl-addr.c
@@ -60,7 +60,6 @@ determine_info (const ElfW(Addr) addr, struct link_map *match, Dl_info *info,
@@ -61,12 +61,12 @@ index e48795871b..482704e77f 100644
matchsym = (ElfW(Sym) *) symtab;
diff --git a/elf/tst-absolute-sym-lib.c b/elf/tst-absolute-sym-lib.c
deleted file mode 100644
-index 2493d76ca5..0000000000
+index 65daf73080..0000000000
--- a/elf/tst-absolute-sym-lib.c
+++ /dev/null
@@ -1,25 +0,0 @@
-/* BZ #19818 absolute symbol calculation shared module.
-- Copyright (C) 2018-2019 Free Software Foundation, Inc.
+- Copyright (C) 2018-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -92,12 +92,12 @@ index 2493d76ca5..0000000000
-}
diff --git a/elf/tst-absolute-sym-lib.lds b/elf/tst-absolute-sym-lib.lds
deleted file mode 100644
-index e71d53e2a3..0000000000
+index 7f5f2e4757..0000000000
--- a/elf/tst-absolute-sym-lib.lds
+++ /dev/null
@@ -1,19 +0,0 @@
-/* BZ #19818 absolute symbol calculation linker script.
-- Copyright (C) 2018-2019 Free Software Foundation, Inc.
+- Copyright (C) 2018-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -117,12 +117,12 @@ index e71d53e2a3..0000000000
-"absolute" = 0x55aa;
diff --git a/elf/tst-absolute-sym.c b/elf/tst-absolute-sym.c
deleted file mode 100644
-index 4af1554929..0000000000
+index bbabf9cafb..0000000000
--- a/elf/tst-absolute-sym.c
+++ /dev/null
@@ -1,38 +0,0 @@
-/* BZ #19818 absolute symbol calculation main executable.
-- Copyright (C) 2018-2019 Free Software Foundation, Inc.
+- Copyright (C) 2018-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -160,7 +160,7 @@ index 4af1554929..0000000000
-
-#include <support/test-driver.c>
diff --git a/sysdeps/generic/ldsodefs.h b/sysdeps/generic/ldsodefs.h
-index f3ba13ee68..556eb7be66 100644
+index 497938ffa2..6499adbf9d 100644
--- a/sysdeps/generic/ldsodefs.h
+++ b/sysdeps/generic/ldsodefs.h
@@ -89,8 +89,7 @@ typedef struct link_map *lookup_t;
@@ -174,5 +174,5 @@ index f3ba13ee68..556eb7be66 100644
/* On some architectures a pointer to a function is not just a pointer
to the actual code of the function but rather an architecture
--
-2.23.0
+2.25.0
diff --git a/PKGBUILD b/PKGBUILD
index bc71d81b1599..d8d6eaff0d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.30.r129.gd7a568af55
+pkgver=2.31.r148.gca843defbc
pkgrel=1
pkgdesc='GNU C Library'
arch=('i686' 'x86_64')
@@ -26,7 +26,7 @@ source=('git+https://sourceware.org/git/glibc.git'
'bz20338.patch')
sha256sums=('SKIP'
'05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de'
- '1f54579c1d8dd0abdb05e20516272753164c9e77e233da1ad2e11da96ed20ba1'
+ '6a3de26cec7b5b3e05090e85e970705454d9d749dcd4a2e1d35bee11d4e3637b'
'7ff38c08e51c4a0a3d7fd2712cf435f700bef078fb8f4e7566424ae3d1754bab')
# remove default hardening for building libraries