summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2019-01-13 14:36:51 -0500
committerEli Schwartz2019-01-13 14:58:16 -0500
commitac969d83f985fde0549d35d84a8b3ef03716ec4b (patch)
tree6c9bd48e667a2795fba637f8fb6536984f61a7ec
parent04289d11f594f716dde46ed79f700e181cf925c2 (diff)
downloadaur-ac969d83f985fde0549d35d84a8b3ef03716ec4b.tar.gz
upgpkg: glibc-git 2.28.r559.ga1b02ae763-1
refresh patch
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch24
-rw-r--r--PKGBUILD4
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75b6348e6974..86b197206ad8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glibc-git
pkgdesc = GNU C Library
- pkgver = 2.28.r261.g6d6ee04622
+ pkgver = 2.28.r559.ga1b02ae763
pkgrel = 1
url = https://www.gnu.org/software/libc/
install = glibc-git.install
@@ -26,7 +26,7 @@ pkgbase = glibc-git
source = bz20338.patch
sha256sums = SKIP
sha256sums = 05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de
- sha256sums = a1973bc50a3cd80aa1745de0622a8496d185b9a16fceb1f3adbe33eb1aafb18b
+ sha256sums = 84ee34285796d7154a92cc6177920d1d9cac361f02c6ef164e13a121dec59d05
sha256sums = 959d4f41edd004bddd9091c4d8c8c3aa07d79a04bfdb89d59f9f26fe5a74d32a
pkgname = glibc-git
diff --git a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
index 780058f84467..7ccfbaec704a 100644
--- a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+++ b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
@@ -1,4 +1,4 @@
-From e4d9bb4a08f3ad518f0f54163f3043ca72c593e3 Mon Sep 17 00:00:00 2001
+From e0cff4a2cace32698e9531bbdbd6e5ce59b5756a Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Fri, 28 Sep 2018 05:19:46 +0000
Subject: [PATCH] Revert "elf: Correct absolute (SHN_ABS) symbol run-time
@@ -18,7 +18,7 @@ This reverts commit e7feec374c635b6a29d65c39ae5e1855528fed39.
delete mode 100644 elf/tst-absolute-sym.c
diff --git a/elf/Makefile b/elf/Makefile
-index d72e7b67f6..91fd26973d 100644
+index 9cf5cd8dfd..1b144d67e2 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -186,7 +186,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
@@ -30,7 +30,7 @@ index d72e7b67f6..91fd26973d 100644
tst-unwind-ctor tst-unwind-main
# reldep9
tests-internal += loadtest unload unload2 circleload1 \
-@@ -273,7 +273,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
+@@ -274,7 +274,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
tst-audit12mod1 tst-audit12mod2 tst-audit12mod3 tst-auditmod12 \
tst-latepthreadmod $(tst-tls-many-dynamic-modules) \
tst-nodelete-dlclose-dso tst-nodelete-dlclose-plugin \
@@ -40,7 +40,7 @@ index d72e7b67f6..91fd26973d 100644
# Most modules build with _ISOMAC defined, but those filtered out
# depend on internal headers.
diff --git a/elf/dl-addr.c b/elf/dl-addr.c
-index e6c7d02094..2250617a73 100644
+index 9d285d76a7..0dd7d1dde9 100644
--- a/elf/dl-addr.c
+++ b/elf/dl-addr.c
@@ -59,7 +59,6 @@ determine_info (const ElfW(Addr) addr, struct link_map *match, Dl_info *info,
@@ -61,12 +61,12 @@ index e6c7d02094..2250617a73 100644
matchsym = (ElfW(Sym) *) symtab;
diff --git a/elf/tst-absolute-sym-lib.c b/elf/tst-absolute-sym-lib.c
deleted file mode 100644
-index 912cb0048a..0000000000
+index e0becab58e..0000000000
--- a/elf/tst-absolute-sym-lib.c
+++ /dev/null
@@ -1,25 +0,0 @@
-/* BZ #19818 absolute symbol calculation shared module.
-- Copyright (C) 2018 Free Software Foundation, Inc.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -92,12 +92,12 @@ index 912cb0048a..0000000000
-}
diff --git a/elf/tst-absolute-sym-lib.lds b/elf/tst-absolute-sym-lib.lds
deleted file mode 100644
-index d4a4128514..0000000000
+index fcb990116a..0000000000
--- a/elf/tst-absolute-sym-lib.lds
+++ /dev/null
@@ -1,19 +0,0 @@
-/* BZ #19818 absolute symbol calculation linker script.
-- Copyright (C) 2018 Free Software Foundation, Inc.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -117,12 +117,12 @@ index d4a4128514..0000000000
-"absolute" = 0x55aa;
diff --git a/elf/tst-absolute-sym.c b/elf/tst-absolute-sym.c
deleted file mode 100644
-index 111491d159..0000000000
+index c641f7ecdf..0000000000
--- a/elf/tst-absolute-sym.c
+++ /dev/null
@@ -1,38 +0,0 @@
-/* BZ #19818 absolute symbol calculation main executable.
-- Copyright (C) 2018 Free Software Foundation, Inc.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -160,7 +160,7 @@ index 111491d159..0000000000
-
-#include <support/test-driver.c>
diff --git a/sysdeps/generic/ldsodefs.h b/sysdeps/generic/ldsodefs.h
-index 95dc87519b..3cac4fa362 100644
+index 37cab6f06b..eb01538256 100644
--- a/sysdeps/generic/ldsodefs.h
+++ b/sysdeps/generic/ldsodefs.h
@@ -72,8 +72,7 @@ typedef struct link_map *lookup_t;
@@ -174,5 +174,5 @@ index 95dc87519b..3cac4fa362 100644
/* On some architectures a pointer to a function is not just a pointer
to the actual code of the function but rather an architecture
--
-2.19.1
+2.20.1
diff --git a/PKGBUILD b/PKGBUILD
index bedebe901f8b..ee7d71e4fb54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.28.r261.g6d6ee04622
+pkgver=2.28.r559.ga1b02ae763
pkgrel=1
pkgdesc='GNU C Library'
arch=('i686' 'x86_64')
@@ -26,7 +26,7 @@ source=('git+https://sourceware.org/git/glibc.git'
'bz20338.patch')
sha256sums=('SKIP'
'05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de'
- 'a1973bc50a3cd80aa1745de0622a8496d185b9a16fceb1f3adbe33eb1aafb18b'
+ '84ee34285796d7154a92cc6177920d1d9cac361f02c6ef164e13a121dec59d05'
'959d4f41edd004bddd9091c4d8c8c3aa07d79a04bfdb89d59f9f26fe5a74d32a')
pkgver() {