summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeptazhou2022-09-20 03:12:55 +0000
committerHeptazhou2022-09-20 03:12:55 +0000
commit75408dd37fb19adaf99dea678c0f7943ad41b1a1 (patch)
treeec9691629412af83fc22f70bfccaac45c750c169
parent5fc50a7591419908ae8099bf46052fef8d5dd284 (diff)
downloadaur-75408dd37fb19adaf99dea678c0f7943ad41b1a1.tar.gz
fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD90
-rw-r--r--locale.gen.txt9
3 files changed, 50 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2166eee38c7d..c936914a21fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glibc-linux4
pkgver = 2.36
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/libc/
arch = x86_64
license = GPL
@@ -12,8 +12,7 @@ pkgbase = glibc-linux4
options = debug
options = staticlibs
options = !lto
- source = https://ftp.gnu.org/gnu/glibc/glibc-2.36.tar.xz
- source = https://ftp.gnu.org/gnu/glibc/glibc-2.36.tar.xz.sig
+ source = git+https://sourceware.org/git/glibc.git#commit=4b95b6e8bbb5a2b6856f707bf3bc3308ebef595a
source = glibc-linux4.patch
source = locale.gen.txt
source = locale-gen
@@ -22,7 +21,6 @@ pkgbase = glibc-linux4
source = sdt-config.h
validpgpkeys = 7273542B39962DF7B299931416792B4EA25340F8
validpgpkeys = BC7C7372637EC10C57D7AA6579C43DFBF1CF2187
- sha256sums = 1c959fea240906226062cb4b1e7ebce71a9f0e3c0836c09e7e3423d434fcfe75
sha256sums = SKIP
sha256sums = 69573c1c4eee6216f4f345647aed938d13994bf19a7e3a6ba9ed8bab85f23bef
sha256sums = fbd57987ca24d71305eda9e0dd76143b422118e12f76b2b0d555f86763e14cd2
diff --git a/PKGBUILD b/PKGBUILD
index 5af562f7c878..7a5a38e42e21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,21 @@
pkgbase=glibc-linux4
pkgname=(glibc-linux4 lib32-glibc-linux4)
-pkgver_=c804cd1c00adde061ca51711f63068c103e94eef
+pkgver_=4b95b6e8bbb5a2b6856f707bf3bc3308ebef595a
pkgver=2.36
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://www.gnu.org/software/libc/"
license=(GPL LGPL)
makedepends=(git gd lib32-gcc-libs python)
options=(debug staticlibs !lto)
+validpgpkeys=(
+ 7273542B39962DF7B299931416792B4EA25340F8 # Carlos O'Donell
+ BC7C7372637EC10C57D7AA6579C43DFBF1CF2187 # Siddhesh Poyarekar
+)
source=(
- # git+https://sourceware.org/git/glibc.git#commit=$pkgver_
- https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
+ git+https://sourceware.org/git/glibc.git#commit=$pkgver_
+ # https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
glibc-linux4.patch
locale.gen.txt
locale-gen
@@ -27,13 +31,9 @@ source=(
sdt.h
sdt-config.h
)
-validpgpkeys=(
- 7273542B39962DF7B299931416792B4EA25340F8 # Carlos O'Donell
- BC7C7372637EC10C57D7AA6579C43DFBF1CF2187 # Siddhesh Poyarekar
-)
sha256sums=(
- # "SKIP"
- "1c959fea240906226062cb4b1e7ebce71a9f0e3c0836c09e7e3423d434fcfe75" "SKIP"
+ "SKIP"
+ # "1c959fea240906226062cb4b1e7ebce71a9f0e3c0836c09e7e3423d434fcfe75" "SKIP"
"69573c1c4eee6216f4f345647aed938d13994bf19a7e3a6ba9ed8bab85f23bef"
"fbd57987ca24d71305eda9e0dd76143b422118e12f76b2b0d555f86763e14cd2"
"7503947e23cecc8307e8f7ce2a792eecb6f72f22d6838b34417c2489a259fde9"
@@ -68,7 +68,7 @@ build() {
--disable-werror
)
- cd -- "$srcdir/glibc-build"
+ cd "${srcdir}"/glibc-build
echo "slibdir=/usr/lib" >> configparms
echo "rtlddir=/usr/lib" >> configparms
@@ -80,7 +80,7 @@ build() {
# remove fortify for building libraries
CFLAGS=${CFLAGS/-Wp,-D_FORTIFY_SOURCE=2/}
- "$srcdir/glibc/configure" \
+ "${srcdir}"/glibc/configure \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
"${_configure_flags[@]}"
@@ -97,7 +97,7 @@ build() {
# build info pages manually for reproducibility
make info
- cd -- "$srcdir/lib32-glibc-build"
+ cd "${srcdir}"/lib32-glibc-build
export CC="gcc -m32 -mstackrealign"
export CXX="g++ -m32 -mstackrealign"
@@ -106,7 +106,7 @@ build() {
echo "sbindir=/usr/bin" >> configparms
echo "rootsbindir=/usr/bin" >> configparms
- "$srcdir/glibc/configure" \
+ "${srcdir}"/glibc/configure \
--host=i686-pc-linux-gnu \
--libdir=/usr/lib32 \
--libexecdir=/usr/lib32 \
@@ -121,11 +121,11 @@ build() {
echo "CFLAGS += -Wp,-D_FORTIFY_SOURCE=2" >> configparms
make -O
+ cd "${srcdir}"/glibc-build
+
# pregenerate C.UTF-8 locale until it is built into glibc
# (https://sourceware.org/glibc/wiki/Proposals/C.UTF-8, FS#74864)
- locale/localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/ \
- || localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/ \
- || true
+ elf/ld.so --library-path "$PWD" locale/localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/
}
check() {
@@ -156,40 +156,42 @@ package_glibc-linux4() {
etc/nscd.conf
)
- make -C glibc-build install_root="$pkgdir" install
- rm -f "$pkgdir"/etc/ld.so.cache
+ make -C glibc-build install_root="${pkgdir}" install
+ rm -f "${pkgdir}"/etc/ld.so.cache
# Shipped in tzdata
- rm -f "$pkgdir"/usr/bin/{tzselect,zdump,zic}
+ rm -f "${pkgdir}"/usr/bin/{tzselect,zdump,zic}
cd glibc
- install -dm755 "$pkgdir"/usr/lib/{locale,systemd/system,tmpfiles.d}
- install -m644 nscd/nscd.conf "$pkgdir/etc/nscd.conf"
- install -m644 nscd/nscd.service "$pkgdir/usr/lib/systemd/system"
- install -m644 nscd/nscd.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/nscd.conf"
- install -dm755 "$pkgdir/var/db/nscd"
+ install -dm755 "${pkgdir}"/usr/lib/{locale,systemd/system,tmpfiles.d}
+ install -m644 nscd/nscd.conf "${pkgdir}"/etc/nscd.conf
+ install -m644 nscd/nscd.service "${pkgdir}"/usr/lib/systemd/system
+ install -m644 nscd/nscd.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/nscd.conf
+ install -dm755 "${pkgdir}"/var/db/nscd
- install -m644 posix/gai.conf "$pkgdir"/etc/gai.conf
+ install -m644 posix/gai.conf "${pkgdir}"/etc/gai.conf
- install -m755 "$srcdir/locale-gen" "$pkgdir/usr/bin"
+ install -m755 "${srcdir}"/locale-gen "${pkgdir}"/usr/bin
# Create /etc/locale.gen
- install -m644 "$srcdir/locale.gen.txt" "$pkgdir/etc/locale.gen"
+ install -m644 "${srcdir}"/locale.gen.txt "${pkgdir}"/etc/locale.gen
sed -e '1,3d' -e 's|/| |g' -e 's|\\| |g' -e 's|^|#|g' \
- "$srcdir/glibc/localedata/SUPPORTED" >> "$pkgdir/etc/locale.gen"
+ "${srcdir}"/glibc/localedata/SUPPORTED >> "${pkgdir}"/etc/locale.gen
+
+ # Add SUPPORTED file to pkg
+ sed -e '1,3d' -e 's|/| |g' -e 's| \\||g' \
+ "${srcdir}"/glibc/localedata/SUPPORTED > "${pkgdir}"/usr/share/i18n/SUPPORTED
- if [[ -f "$srcdir/C.UTF-8" ]]; then
- # install C.UTF-8 so that it is always available
- install -dm755 "$pkgdir/usr/lib/locale"
- cp -r "$srcdir/C.UTF-8" -t "$pkgdir/usr/lib/locale"
- sed -i '/#C\.UTF-8 /d' "$pkgdir/etc/locale.gen"
- fi
+ # install C.UTF-8 so that it is always available
+ install -dm755 "${pkgdir}"/usr/lib/locale
+ cp -r "${srcdir}"/C.UTF-8 -t "${pkgdir}"/usr/lib/locale
+ sed -i '/#C\.UTF-8 /d' "${pkgdir}"/etc/locale.gen
# Provide tracing probes to libstdc++ for exceptions, possibly for other
# libraries too. Useful for gdb's catch command.
- install -Dm644 "$srcdir/sdt.h" "$pkgdir/usr/include/sys/sdt.h"
- install -Dm644 "$srcdir/sdt-config.h" "$pkgdir/usr/include/sys/sdt-config.h"
+ install -Dm644 "${srcdir}"/sdt.h "${pkgdir}"/usr/include/sys/sdt.h
+ install -Dm644 "${srcdir}"/sdt-config.h "${pkgdir}"/usr/include/sys/sdt-config.h
}
package_lib32-glibc-linux4() {
@@ -201,19 +203,19 @@ package_lib32-glibc-linux4() {
cd lib32-glibc-build
- make install_root="$pkgdir" install
- rm -rf "$pkgdir"/{etc,sbin,usr/{bin,sbin,share},var}
+ make install_root="${pkgdir}" install
+ rm -rf "${pkgdir}"/{etc,sbin,usr/{bin,sbin,share},var}
# We need to keep 32 bit specific header files
- find "$pkgdir/usr/include" -type f -not -name '*-32.h' -delete
+ find "${pkgdir}"/usr/include -type f -not -name '*-32.h' -delete
# Dynamic linker
- install -d "$pkgdir/usr/lib"
- ln -s ../lib32/ld-linux.so.2 "$pkgdir/usr/lib/"
+ install -d "${pkgdir}"/usr/lib
+ ln -s ../lib32/ld-linux.so.2 "${pkgdir}"/usr/lib/
# Add lib32 paths to the default library search path
- install -Dm644 "$srcdir/lib32-glibc.conf" "$pkgdir/etc/ld.so.conf.d/lib32-glibc.conf"
+ install -Dm644 "${srcdir}"/lib32-glibc.conf "${pkgdir}"/etc/ld.so.conf.d/lib32-glibc.conf
# Symlink /usr/lib32/locale to /usr/lib/locale
- ln -s ../lib/locale "$pkgdir/usr/lib32/locale"
+ ln -s ../lib/locale "${pkgdir}"/usr/lib32/locale
}
diff --git a/locale.gen.txt b/locale.gen.txt
index 4b9e0c479a8f..e32af2962797 100644
--- a/locale.gen.txt
+++ b/locale.gen.txt
@@ -9,14 +9,9 @@
# where <locale> is one of the locales given in /usr/share/i18n/locales
# and <charset> is one of the character sets listed in /usr/share/i18n/charmaps
#
-# Examples:
-# en_US UTF-8
-# de_DE UTF-8
-# de_DE@euro ISO-8859-15
-#
# The locale-gen command will generate all the locales,
# placing them in /usr/lib/locale.
#
-# A list of supported locales is included in this file.
-# Uncomment the ones you need.
+# A list of supported locales is given in /usr/share/i18n/SUPPORTED
+# and is included in this file. Uncomment the needed locales below.
#