summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Stewart2017-05-31 12:03:15 +0100
committerPatrick Stewart2017-05-31 12:05:07 +0100
commit4063c9486439ef8352123d6b0326dd521b253296 (patch)
treefdcea9ecc848ec862d5cf8b65214e36326750506
downloadaur-4063c9486439ef8352123d6b0326dd521b253296.tar.gz
Glibc 2.25-2 with Windows Subsystem for Linux incompatible change backed out
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD150
-rw-r--r--glibc.install5
-rw-r--r--locale-gen42
-rw-r--r--locale.gen.txt23
5 files changed, 252 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d992eb91d4e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = glibc-wsl
+ pkgdesc = GNU C Library
+ pkgver = 2.25
+ pkgrel = 2
+ url = http://www.gnu.org/software/libc
+ install = glibc.install
+ arch = i686
+ arch = x86_64
+ groups = base
+ license = GPL
+ license = LGPL
+ makedepends = gcc>=6
+ makedepends = git
+ depends = linux-api-headers>=4.10
+ depends = tzdata
+ depends = filesystem
+ provides = glibc=2.25-2
+ conflicts = glibc
+ options = !strip
+ options = staticlibs
+ backup = etc/gai.conf
+ backup = etc/locale.gen
+ backup = etc/nscd.conf
+ source = git+https://sourceware.org/git/glibc.git#commit=ccb4fd7a657b0fbc4890c98f4586d58a135fc583
+ source = locale.gen.txt
+ source = locale-gen
+ md5sums = SKIP
+ md5sums = 07ac979b6ab5eeb778d55f041529d623
+ md5sums = 476e9113489f93b348b21e144b6a8fcf
+
+pkgname = glibc-wsl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62e78f524488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,150 @@
+# Maintainer: Patrick Stewart <patstew@gmail.com>
+
+_pkgname=glibc
+pkgname=glibc-wsl
+pkgver=2.25
+pkgrel=2
+_commit=ccb4fd7a657b0fbc4890c98f4586d58a135fc583
+pkgdesc="GNU C Library"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/libc"
+license=('GPL' 'LGPL')
+groups=('base')
+depends=('linux-api-headers>=4.10' 'tzdata' 'filesystem')
+makedepends=('gcc>=6' 'git')
+provides=("${_pkgname}=${pkgver}-${pkgrel}")
+conflicts=("${_pkgname}")
+backup=(etc/gai.conf
+ etc/locale.gen
+ etc/nscd.conf)
+options=('!strip' 'staticlibs')
+install=glibc.install
+source=(git+https://sourceware.org/git/glibc.git#commit=${_commit}
+ locale.gen.txt
+ locale-gen)
+md5sums=('SKIP'
+ '07ac979b6ab5eeb778d55f041529d623'
+ '476e9113489f93b348b21e144b6a8fcf')
+
+prepare() {
+ mkdir -p glibc-build
+ git -C ${srcdir}/glibc revert 4b4d4056bb15 && exit 0
+ git -C ${srcdir}/glibc reset -- ChangeLog
+ git -C ${srcdir}/glibc commit -m "Revert spawn changes for WSL"
+}
+
+build() {
+ cd glibc-build
+
+ if [[ ${CARCH} = "i686" ]]; then
+ # Hack to fix NPTL issues with Xen, only required on 32bit platforms
+ export CFLAGS="${CFLAGS} -mno-tls-direct-seg-refs"
+ fi
+
+ echo "slibdir=/usr/lib" >> configparms
+ echo "rtlddir=/usr/lib" >> configparms
+ echo "sbindir=/usr/bin" >> configparms
+ echo "rootsbindir=/usr/bin" >> configparms
+
+ # remove fortify for building libraries
+ CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
+
+ ../${_pkgname}/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --with-headers=/usr/include \
+ --with-bugurl=https://bugs.archlinux.org/ \
+ --enable-add-ons \
+ --enable-obsolete-rpc \
+ --enable-kernel=2.6.32 \
+ --enable-bind-now \
+ --disable-profile \
+ --enable-stackguard-randomization \
+ --enable-stack-protector=strong \
+ --enable-lock-elision \
+ --enable-multi-arch \
+ --disable-werror
+
+ # build libraries with fortify disabled
+ echo "build-programs=no" >> configparms
+ make
+
+ # re-enable fortify for programs
+ sed -i "/build-programs=/s#no#yes#" configparms
+
+ echo "CC += -D_FORTIFY_SOURCE=2" >> configparms
+ echo "CXX += -D_FORTIFY_SOURCE=2" >> configparms
+ make
+}
+
+check() {
+ cd glibc-build
+
+ # remove fortify in preparation to run test-suite
+ sed -i '/FORTIFY/d' configparms
+
+ # some failures are "expected"
+ make check || true
+}
+
+package() {
+ cd glibc-build
+
+ install -dm755 ${pkgdir}/etc
+ touch ${pkgdir}/etc/ld.so.conf
+
+ make install_root=${pkgdir} install
+
+ rm -f ${pkgdir}/etc/ld.so.{cache,conf}
+
+ install -dm755 ${pkgdir}/usr/lib/{locale,systemd/system,tmpfiles.d}
+
+ install -m644 ${srcdir}/${_pkgname}/nscd/nscd.conf ${pkgdir}/etc/nscd.conf
+ install -m644 ${srcdir}/${_pkgname}/nscd/nscd.service ${pkgdir}/usr/lib/systemd/system
+ install -m644 ${srcdir}/${_pkgname}/nscd/nscd.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/nscd.conf
+
+ install -m644 ${srcdir}/${_pkgname}/posix/gai.conf ${pkgdir}/etc/gai.conf
+
+ install -m755 ${srcdir}/locale-gen ${pkgdir}/usr/bin
+
+ # create /etc/locale.gen
+ install -m644 ${srcdir}/locale.gen.txt ${pkgdir}/etc/locale.gen
+ sed -e '1,3d' -e 's|/| |g' -e 's|\\| |g' -e 's|^|#|g' \
+ ${srcdir}/glibc/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
+
+ # Do not strip the following files for improved debugging support
+ # ("improved" as in not breaking gdb and valgrind...):
+ # ld-${pkgver}.so
+ # libc-${pkgver}.so
+ # libpthread-${pkgver}.so
+ # libthread_db-1.0.so
+
+ cd $pkgdir
+ strip $STRIP_BINARIES usr/bin/{gencat,getconf,getent,iconv,iconvconfig} \
+ usr/bin/{ldconfig,locale,localedef,nscd,makedb} \
+ usr/bin/{pcprofiledump,pldd,rpcgen,sln,sprof} \
+ usr/lib/getconf/*
+ if [[ $CARCH = "i686" ]]; then
+ strip $STRIP_BINARIES usr/bin/lddlibc4
+ fi
+
+ strip $STRIP_STATIC usr/lib/lib{anl,BrokenLocale,c{,_nonshared},crypt}.a \
+ usr/lib/lib{dl,g,ieee,mcheck,nsl,pthread{,_nonshared}}.a \
+ usr/lib/lib{resolv,rpcsvc,rt,util}.a
+
+ strip $STRIP_SHARED usr/lib/lib{anl,BrokenLocale,cidn,crypt}-${pkgver}.so \
+ usr/lib/libnss_{compat,db,dns,files,hesiod,nis,nisplus}-*.so \
+ usr/lib/lib{dl,m,nsl,resolv,rt,util}-${pkgver}.so \
+ usr/lib/lib{memusage,pcprofile,SegFault}.so \
+ usr/lib/{audit,gconv}/*.so || true
+
+ if [[ $CARCH = "x86_64" ]]; then
+ strip $STRIP_STATIC usr/lib/lib{m-${pkgver},mvec{,_nonshared}}.a
+ strip $STRIP_SHARED usr/lib/libmvec-*.so
+ fi
+
+ if [[ $CARCH = "i686" ]]; then
+ strip $STRIP_STATIC usr/lib/libm.a
+ fi
+}
diff --git a/glibc.install b/glibc.install
new file mode 100644
index 000000000000..351f05b263cb
--- /dev/null
+++ b/glibc.install
@@ -0,0 +1,5 @@
+post_upgrade() {
+ locale-gen
+
+ ldconfig -r .
+}
diff --git a/locale-gen b/locale-gen
new file mode 100644
index 000000000000..5aff344c4e91
--- /dev/null
+++ b/locale-gen
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+set -e
+
+LOCALEGEN=/etc/locale.gen
+LOCALES=/usr/share/i18n/locales
+if [ -n "$POSIXLY_CORRECT" ]; then
+ unset POSIXLY_CORRECT
+fi
+
+
+[ -f $LOCALEGEN -a -s $LOCALEGEN ] || exit 0;
+
+# Remove all old locale dir and locale-archive before generating new
+# locale data.
+rm -rf /usr/lib/locale/* || true
+
+umask 022
+
+is_entry_ok() {
+ if [ -n "$locale" -a -n "$charset" ] ; then
+ true
+ else
+ echo "error: Bad entry '$locale $charset'"
+ false
+ fi
+}
+
+echo "Generating locales..."
+while read locale charset; do \
+ case $locale in \#*) continue;; "") continue;; esac; \
+ is_entry_ok || continue
+ echo -n " `echo $locale | sed 's/\([^.\@]*\).*/\1/'`"; \
+ echo -n ".$charset"; \
+ echo -n `echo $locale | sed 's/\([^\@]*\)\(\@.*\)*/\2/'`; \
+ echo -n '...'; \
+ if [ -f $LOCALES/$locale ]; then input=$locale; else \
+ input=`echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; fi; \
+ localedef -i $input -c -f $charset -A /usr/share/locale/locale.alias $locale; \
+ echo ' done'; \
+done < $LOCALEGEN
+echo "Generation complete."
diff --git a/locale.gen.txt b/locale.gen.txt
new file mode 100644
index 000000000000..ccdd817342c7
--- /dev/null
+++ b/locale.gen.txt
@@ -0,0 +1,23 @@
+# Configuration file for locale-gen
+#
+# lists of locales that are to be generated by the locale-gen command.
+#
+# Each line is of the form:
+#
+# <locale> <charset>
+#
+# where <locale> is one of the locales given in /usr/share/i18n/locales
+# and <charset> is one of the character sets listed in /usr/share/i18n/charmaps
+#
+# Examples:
+# en_US ISO-8859-1
+# en_US.UTF-8 UTF-8
+# de_DE ISO-8859-1
+# de_DE@euro ISO-8859-15
+#
+# The locale-gen command will generate all the locales,
+# placing them in /usr/lib/locale.
+#
+# A list of supported locales is included in this file.
+# Uncomment the ones you need.
+#