summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD1ceWard2021-10-28 10:01:40 +0200
committerD1ceWard2021-10-28 10:01:40 +0200
commit117a250eba7bd2454bde64d24e63272cfd88eb2a (patch)
treeaaec366c4542f918e8d60030eaaa67341daf08ae
parent3a032a49127e4250b3026b5db09cf12bea14ed09 (diff)
downloadaur-117a250eba7bd2454bde64d24e63272cfd88eb2a.tar.gz
upgpkg: gliderlabs-sigil 0.7.1-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD14
4 files changed, 12 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c16f5edcf71..b2e7410de0bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = gliderlabs-sigil
pkgdesc = Standalone string interpolator and template processor
- pkgver = 0.6.0
- pkgrel = 2
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://github.com/gliderlabs/sigil
arch = x86_64
license = BSD
conflicts = sigil
- source = https://github.com/gliderlabs/sigil/releases/download/v0.6.0/sigil_0.6.0_Linux_x86_64.tgz
- source = LICENSE
- sha256sums = 303c9d9aaa24da05998e7138cfa96e3ee032ff3ce4a89cf682203b94f2cfe15e
+ source = https://github.com/gliderlabs/sigil/releases/download/v0.7.1/gliderlabs-sigil_0.7.1_linux_amd64.tgz
+ source = https://raw.githubusercontent.com/gliderlabs/sigil/master/LICENSE
+ sha256sums = 525d7cf80df29a9bbbaa7266ac41efd87d6713f6d64031aa9b19963333e0560b
sha256sums = 90b8e840cef9b3c39c1419cf394efe2480544056f55d7d709f3c1b4f47fe9321
pkgname = gliderlabs-sigil
diff --git a/.gitignore b/.gitignore
index f9ecc0a87e76..0aff66deac4a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/src/
/pkg/
/*.tgz
+/LICENSE
/*.pkg.tar.zst
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index d7241378e949..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-Copyright (c) 2015 Glider Labs, LLC
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
- * Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
- * Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- * Neither the name of the copyright holder nor the
- names of its contributors may be used to endorse or promote products
- derived from this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDERS BE LIABLE FOR ANY
-DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 2dec279ebf74..4b8bdc74beb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=gliderlabs-sigil
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc='Standalone string interpolator and template processor'
arch=('x86_64')
url='https://github.com/gliderlabs/sigil'
license=('BSD')
# a package with the same name exists and provides a binary with the same name
conflicts=('sigil')
-source=("${url}/releases/download/v${pkgver}/sigil_${pkgver}_Linux_x86_64.tgz"
- 'LICENSE')
-sha256sums=('303c9d9aaa24da05998e7138cfa96e3ee032ff3ce4a89cf682203b94f2cfe15e'
+source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64.tgz"
+ "https://raw.githubusercontent.com/gliderlabs/sigil/master/LICENSE")
+sha256sums=('525d7cf80df29a9bbbaa7266ac41efd87d6713f6d64031aa9b19963333e0560b'
'90b8e840cef9b3c39c1419cf394efe2480544056f55d7d709f3c1b4f47fe9321')
package() {
cd "${srcdir}"
- install -Dm755 sigil "${pkgdir}/usr/bin/sigil"
-
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 "${pkgname}-amd64" "${pkgdir}/usr/bin/sigil"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}