summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authord1ceward2020-11-19 07:28:15 +0100
committerd1ceward2020-11-19 07:28:15 +0100
commite0feae5bd4a997d7e32586be70be465d532bf09a (patch)
treeef12adb829529c23f921626138867d6808efe757
parent4b905fdf1126324000675aa53ffd5ee6e1904d65 (diff)
downloadaur-e0feae5bd4a997d7e32586be70be465d532bf09a.tar.gz
upgpkg: gliderlabs-sigil 0.6.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD13
4 files changed, 38 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24393fc375db..b3511160686d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
-# Generated by mksrcinfo v8
-# Mon Feb 22 19:40:54 UTC 2016
pkgbase = gliderlabs-sigil
pkgdesc = Standalone string interpolator and template processor
- pkgver = 0.4.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/gliderlabs/sigil
arch = x86_64
license = BSD
conflicts = sigil
- source = https://github.com/gliderlabs/sigil/releases/download/v0.4.0/sigil_0.4.0_Linux_x86_64.tgz
- sha256sums = c503bc15fba88d08fe7ba350fc02e61c4757d13f349f56cf5b7977f8139d5843
+ source = https://github.com/gliderlabs/sigil/releases/download/v0.6.0/sigil_0.6.0_Linux_x86_64.tgz
+ source = LICENSE
+ sha256sums = 303c9d9aaa24da05998e7138cfa96e3ee032ff3ce4a89cf682203b94f2cfe15e
+ sha256sums = 90b8e840cef9b3c39c1419cf394efe2480544056f55d7d709f3c1b4f47fe9321
pkgname = gliderlabs-sigil
diff --git a/.gitignore b/.gitignore
index a259674dc927..6bc6c3879ebc 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
src/
pkg/
-*.tar.xz
+*.tar
*.tgz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d7241378e949
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2015 Glider Labs, LLC
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the copyright holder nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDERS BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index f2afaf49b5e2..f5055dcd1178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Morris Jobke <hey AT morrisjobke DOT de>
+# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=gliderlabs-sigil
-pkgver=0.4.0
+pkgver=0.6.0
pkgrel=1
pkgdesc='Standalone string interpolator and template processor'
arch=('x86_64')
@@ -10,9 +10,12 @@ license=('BSD')
# a package with the same name exists and provides a binary with the same name
conflicts=('sigil')
-source=("https://github.com/gliderlabs/sigil/releases/download/v${pkgver}/sigil_${pkgver}_Linux_x86_64.tgz")
-sha256sums=('c503bc15fba88d08fe7ba350fc02e61c4757d13f349f56cf5b7977f8139d5843')
+source=("https://github.com/gliderlabs/sigil/releases/download/v${pkgver}/sigil_${pkgver}_Linux_x86_64.tgz"
+ 'LICENSE')
+sha256sums=('303c9d9aaa24da05998e7138cfa96e3ee032ff3ce4a89cf682203b94f2cfe15e'
+ '90b8e840cef9b3c39c1419cf394efe2480544056f55d7d709f3c1b4f47fe9321')
package(){
- install -Dm 755 sigil "$pkgdir"/usr/bin/sigil
+ install -Dm755 sigil "$pkgdir"/usr/bin/sigil
+ install -Dm7644 LICENSE "${pkgdir}/usr/share/licenses/gliderlabs-sigil/LICENSE"
}