summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Johner2018-10-02 20:49:17 +0200
committerMoritz Johner2018-10-02 20:49:17 +0200
commit6a4d1e7f38ec4ddb9a22587d3ed4eff39e186fb6 (patch)
tree7d8bd2cdd2f9cd6c5ec3f96994c661bb6518a390
downloadaur-6a4d1e7f38ec4ddb9a22587d3ed4eff39e186fb6.tar.gz
initial commit: release 0.31
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a67f8337da1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = glitchlock
+ pkgdesc = a glitch art lockscreen for linux
+ pkgver = 0.31
+ pkgrel = 1
+ url = https://github.com/moolen/glitchlock
+ arch = x86_64
+ license = APACHE
+ makedepends = go>=1.8
+ depends = glibc
+ depends = pam
+ depends = libx11
+ source = glitchlock-0.31.tar.gz::https://github.com/moolen/glitchlock/archive/0.31.tar.gz
+ md5sums = c1e1ab42913024cc543802d3261fe386
+
+pkgname = glitchlock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4549dd3a776f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Moritz Johner <beller.moritz@googlemail.com>
+pkgname=glitchlock
+pkgver=0.31
+pkgrel=1
+pkgdesc="a glitch art lockscreen for linux"
+arch=('x86_64')
+url="https://github.com/moolen/glitchlock"
+license=('APACHE')
+groups=()
+depends=(glibc pam libx11)
+makedepends=('go>=1.8')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/moolen/${pkgname}/archive/${pkgver}.tar.gz")
+noextract=()
+md5sums=('c1e1ab42913024cc543802d3261fe386')
+
+build() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ install -Dm0755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}
+