summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Moore2019-06-09 16:15:23 -0400
committerAaron Moore2019-06-09 16:15:23 -0400
commit27e325de7d3b9f23698081d4c3e29dc92f99224f (patch)
treef9505edb1de62efbc27dfbbca780b00dcb8137f0
downloadaur-27e325de7d3b9f23698081d4c3e29dc92f99224f.tar.gz
Initial commit of gll-lock.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
-rw-r--r--install-patch.patch49
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f135f26dce3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gllock-git
+ pkgdesc = Not so simple opengl based X display locker utility
+ pkgver = r64.c77658b
+ pkgrel = 1
+ url = https://github.com/kuravih/gllock
+ arch = x86_64
+ license = MIT
+ depends = git
+ depends = xorgproto
+ depends = glew
+ source = git+https://github.com/kuravih/gllock.git
+ md5sums = SKIP
+
+pkgname = gllock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8487cce3d16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Aaron Moore <aaron@atamisk.net>
+pkgname=gllock-git
+pkgver=r64.c77658b
+pkgrel=1
+epoch=
+pkgdesc="Not so simple opengl based X display locker utility"
+arch=('x86_64')
+url="https://github.com/kuravih/gllock"
+license=('MIT')
+depends=('git' 'xorgproto' 'glew')
+makedepends=()
+optdepends=()
+source=("git+https://github.com/kuravih/gllock.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch < ../../install-patch.patch
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ pwd
+ make all
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/install-patch.patch b/install-patch.patch
new file mode 100644
index 000000000000..365306f89e10
--- /dev/null
+++ b/install-patch.patch
@@ -0,0 +1,49 @@
+From b7548cf91a3eccbdf66e7702241f1047d8a4c724 Mon Sep 17 00:00:00 2001
+From: Aaron Moore <aaron@atamisk.net>
+Date: Sun, 9 Jun 2019 09:04:12 -0400
+Subject: [PATCH] Removed symlink to user's home directory.
+
+---
+ Makefile | 3 +--
+ config.mk | 4 ++--
+ 2 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 979f943..deba568 100644
+--- a/Makefile
++++ b/Makefile
+@@ -42,8 +42,7 @@ install: all
+ @cp -f gllock ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/gllock
+ @chmod u+s ${DESTDIR}${PREFIX}/bin/gllock
+- @ln -sr shaders ${SHADER_LOCATION}
+-
++ @install -Dt ${DESTDIR}${SHADER_LOCATION} shaders/*
+ uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+ @rm -f ${DESTDIR}${PREFIX}/bin/gllock
+diff --git a/config.mk b/config.mk
+index ce5cbf6..23e8408 100644
+--- a/config.mk
++++ b/config.mk
+@@ -4,7 +4,7 @@ VERSION = 0.1-alpha
+ # Customize below to fit your system
+
+ # paths
+-SHADER_LOCATION = $(HOME)/.gllock
++SHADER_LOCATION = /usr/lib/gllock/shaders/
+
+ # shader
+ # FRGMNT_SHADER = blur.fragment.glsl
+@@ -14,7 +14,7 @@ FRGMNT_SHADER = circle.fragment.glsl
+ # FRGMNT_SHADER = ascii.fragment.glsl
+ # FRGMNT_SHADER = crt.fragment.glsl
+
+-PREFIX = /usr/local
++PREFIX = /usr
+
+ X11INC = /usr/X11R6/include
+ X11LIB = /usr/X11R6/lib
+--
+2.21.0
+