summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2016-11-13 06:34:33 +0900
committerJiachen Yang2016-11-13 06:34:33 +0900
commit066037f8cfa35d19f98fb603e50d8884590832e3 (patch)
treeaec8735b1cc03881bc62f640ef971b2a66acc84d
parentb1a2a911ef58b5ceca906d04018caac39da0aebf (diff)
downloadaur-066037f8cfa35d19f98fb603e50d8884590832e3.tar.gz
fix builds by backport patches
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51dcdab9909e..cce2267a35fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = glmark2
pkgdesc = OpenGL (ES) 2.0 benchmark
pkgver = 2014.03
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/glmark2
arch = i686
arch = x86_64
@@ -9,13 +9,17 @@ pkgbase = glmark2
license = zlib
license = custom
depends = libjpeg-turbo
- depends = libpng12
+ depends = libpng
depends = libx11
depends = libxcb
depends = libgl
depends = python2
source = https://launchpad.net/glmark2/trunk/2014.03/+download/glmark2-2014.03.tar.gz
+ source = pr24.patch::https://patch-diff.githubusercontent.com/raw/glmark2/glmark2/pull/24.patch
+ source = libpng16.patch::https://github.com/glmark2/glmark2/commit/499aa81a68fb4c8aac1c80f0d6a4cce05941c4cc.patch
md5sums = 739859cf57d4c8a23452c43e84f66e56
+ md5sums = 108cbcdf594782dbdcb5908f68db86d7
+ md5sums = e1e498bbaf059a1ce886999b25e6ed78
pkgname = glmark2
diff --git a/PKGBUILD b/PKGBUILD
index 00ec206cd944..536d3ed9c41d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,27 @@
pkgname=glmark2
pkgver=2014.03
-pkgrel=1
+pkgrel=2
pkgdesc="OpenGL (ES) 2.0 benchmark"
arch=('i686' 'x86_64')
url="https://launchpad.net/glmark2"
license=('GPL' 'zlib' 'custom')
groups=()
-depends=('libjpeg-turbo' 'libpng12' 'libx11' 'libxcb' 'libgl' 'python2')
+depends=('libjpeg-turbo' 'libpng' 'libx11' 'libxcb' 'libgl' 'python2')
makedepends=()
optdepends=()
-source=(https://launchpad.net/glmark2/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz)
-md5sums=('739859cf57d4c8a23452c43e84f66e56')
+source=("https://launchpad.net/glmark2/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz"
+ 'pr24.patch::https://patch-diff.githubusercontent.com/raw/glmark2/glmark2/pull/24.patch'
+ 'libpng16.patch::https://github.com/glmark2/glmark2/commit/499aa81a68fb4c8aac1c80f0d6a4cce05941c4cc.patch')
+md5sums=('739859cf57d4c8a23452c43e84f66e56'
+ '108cbcdf594782dbdcb5908f68db86d7'
+ 'e1e498bbaf059a1ce886999b25e6ed78')
+
+prepare(){
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 <../pr24.patch
+ patch -p1 <../libpng16.patch
+}
build() {
cd "$srcdir/$pkgname-$pkgver"