summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-15 08:56:30 -0600
committerMark Wagie2021-04-15 08:56:30 -0600
commit31b4cf9512c0626db10c3b0d74c281debaf61e3f (patch)
treeedf0d90e2ef232d45e48a26f7b9958babdc6cff3
parent2716c486b5447b837b9ce2e4536138acf408954c (diff)
downloadaur-31b4cf9512c0626db10c3b0d74c281debaf61e3f.tar.gz
2021.02
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
3 files changed, 37 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00a48167bc03..78c84d04b275 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = glmark2
- pkgdesc = OpenGL (ES) 2.0 benchmark
- pkgver = 2020.04
+ pkgdesc = An OpenGL 2.0 and ES 2.0 benchmark
+ pkgver = 2021.02
pkgrel = 1
- url = https://launchpad.net/glmark2
- arch = i686
+ url = https://github.com/glmark2/glmark2
arch = x86_64
license = GPL
- license = zlib
license = custom
+ makedepends = meson
+ makedepends = systemd
+ makedepends = wayland-protocols
+ depends = egl-wayland
depends = libjpeg-turbo
depends = libpng
depends = libx11
- depends = libxcb
- depends = libgl
- depends = python2
- source = https://github.com/glmark2/glmark2/archive/2020.04.tar.gz
- md5sums = a90713700a740180fef3576f7ee3c9db
+ depends = mesa
+ depends = systemd-libs
+ source = glmark2-2021.02.tar.gz::https://github.com/glmark2/glmark2/archive/2021.02.tar.gz
+ sha256sums = bebadb78c13aea5e88ed892e5563101ccb745b75f1dc86a8fc7229f00d78cbf1
pkgname = glmark2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index a4616091c448..ff23b3496e3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
-# Maintainer: farseerfc <farseerfc@gmail.com>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: farseerfc <farseerfc@gmail.com>
pkgname=glmark2
-pkgver=2020.04
+pkgver=2021.02
pkgrel=1
-pkgdesc="OpenGL (ES) 2.0 benchmark"
-arch=('i686' 'x86_64')
-url="https://launchpad.net/glmark2"
-license=('GPL' 'zlib' 'custom')
-groups=()
-depends=('libjpeg-turbo' 'libpng' 'libx11' 'libxcb' 'libgl' 'python2')
-makedepends=()
-optdepends=()
-source=("https://github.com/glmark2/glmark2/archive/$pkgver.tar.gz")
-md5sums=('a90713700a740180fef3576f7ee3c9db')
-
-prepare(){
- cd "$srcdir/$pkgname-$pkgver"
- sed -i "s|-Werror ||g" wscript
-}
+pkgdesc="An OpenGL 2.0 and ES 2.0 benchmark"
+arch=('x86_64')
+url="https://github.com/glmark2/glmark2"
+license=('GPL' 'custom')
+depends=('egl-wayland' 'libjpeg-turbo' 'libpng' 'libx11' 'mesa' 'systemd-libs')
+makedepends=('meson' 'systemd' 'wayland-protocols')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('bebadb78c13aea5e88ed892e5563101ccb745b75f1dc86a8fc7229f00d78cbf1')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 ./waf configure --prefix=/usr --with-flavors x11-gl,x11-glesv2
- python2 ./waf
+ arch-meson "$pkgname-$pkgver" build \
+ -Dflavors=drm-gl,drm-glesv2,wayland-gl,wayland-glesv2,x11-gl,x11-glesv2
+ meson compile -C build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 ./waf install --destdir="$pkgdir/"
+ DESTDIR="$pkgdir" meson install -C build
+
+ cd "$pkgname-$pkgver"
+ install -Dm644 COPYING.SGI -t "$pkgdir/usr/share/licenses/$pkgname"
}