summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-03-15 16:18:25 -0500
committerfrealgagu2018-03-15 16:18:25 -0500
commit7b4c6d676a87a3fabe33a48254d1259165266c7b (patch)
treee73263e31d94251d6d523805ecf61f3419b900fa
parent6c5e42ef4b9362cdc192c2db99a59a836aab88be (diff)
downloadaur-7b4c6d676a87a3fabe33a48254d1259165266c7b.tar.gz
Change of maintainer
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f9d4a2a5236..014e0ade071e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = global
pkgdesc = A source code tag system
pkgver = 6.6.2
- pkgrel = 2
+ pkgrel = 3
url = https://www.gnu.org/software/global/
arch = i686
arch = x86_64
license = GPL
makedepends = python
- depends = libltdl
depends = bash
+ depends = libltdl
depends = perl
depends = sqlite
- optdepends = idutils
optdepends = ctags
- optdepends = python-pygments
optdepends = emacs
+ optdepends = idutils
+ optdepends = python-pygments
optdepends = vim
options = !emptydirs
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index d7528979c131..07d3d218caae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Randy Ramos <rramos1295 \at\ gmail \dot\ com>
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Randy Ramos <rramos1295 \at\ gmail \dot\ com>
# Contributor: Peter Vasil <mail@petervasil.net>
# Contributor: Lucas De Marchi <lucas.de.marchi@gmail.com>
# Contributor: Matthias Meulien <orontee@gmail.com>
pkgname=global
pkgver=6.6.2
-pkgrel=2
+pkgrel=3
pkgdesc="A source code tag system"
-arch=('i686' 'x86_64')
-url="https://www.gnu.org/software/global/"
-license=('GPL')
-depends=('libltdl' 'bash' 'perl' 'sqlite')
-optdepends=('idutils' 'ctags' 'python-pygments' 'emacs' 'vim')
-makedepends=('python')
+arch=("i686" "x86_64")
+url="https://www.gnu.org/software/${pkgname}/"
+license=("GPL")
+depends=("bash" "libltdl" "perl" "sqlite")
+optdepends=("ctags" "emacs" "idutils" "python-pygments" "vim")
+makedepends=("python")
options=(!emptydirs !libtool)
source=("https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('43c64711301c2caf40dc56d7b91dd03d2b882a31fa31812bf20de0c8fb2e717f')
+sha256sums=("43c64711301c2caf40dc56d7b91dd03d2b882a31fa31812bf20de0c8fb2e717f")
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -24,13 +25,16 @@ prepare() {
# Package idutils from AUR installs lid as lid-idutils
# See: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=idutils
msg "Change idutils lid executable name to lid-idutils"
- sed -i 's/usable("lid")/usable("lid-idutils")/g' global/global.c
+ sed -i 's/usable("lid")/usable("lid-idutils")/g' ${pkgname}/${pkgname}.c
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
autoreconf -fi
- ./configure --prefix=/usr --with-exuberant-ctags=/usr/bin/ctags --with-sqlite3
+ ./configure \
+ --prefix=/usr \
+ --with-exuberant-ctags=/usr/bin/ctags \
+ --with-sqlite3
make -j4
}