summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuezk2021-04-25 02:32:11 +0000
committeryuezk2021-04-25 02:32:11 +0000
commit91574656a05b5836aed29651a7d3c7497caaf765 (patch)
treeb6875905c1e506ec2208ea9a22b4a25b694e7018
parentccc5df70d2990e3e0eb73967029b2985e53308f6 (diff)
downloadaur-91574656a05b5836aed29651a7d3c7497caaf765.tar.gz
Release v1.2.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e4e7330086d..73f9ede6b72d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = globalprotect-openconnect
pkgdesc = A GlobalProtect VPN client (GUI) for Linux based on Openconnect and built with Qt5, supports SAML auth mode.
- pkgver = 1.2.7
+ pkgver = 1.2.8
pkgrel = 1
url = https://github.com/yuezk/GlobalProtect-openconnect
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = globalprotect-openconnect
depends = qt5-base
depends = qt5-webengine
depends = qt5-websockets
- source = GlobalProtect-openconnect-1.2.7.tar.gz::https://github.com/yuezk/GlobalProtect-openconnect/archive/v1.2.7.tar.gz
+ source = GlobalProtect-openconnect-1.2.8.tar.gz::https://github.com/yuezk/GlobalProtect-openconnect/archive/v1.2.8.tar.gz
source = https://github.com/itay-grudev/SingleApplication/archive/v3.0.19.tar.gz
source = https://github.com/SergiusTheBest/plog/archive/1.1.5.tar.gz
- sha256sums = dc99b46e0b0fe793273accac63cee1432008cc6717a679a05c43ee79d08584d0
+ sha256sums = b10a23f04681f14a71240272765882e56618bbf696b680e6aeebcdce7963aa24 -
sha256sums = 9405fd259288b2a862e91e5135bccee936f0438e1b32c13603277132309d15e0
sha256sums = 6c80b4701183d2415bec927e1f5ca9b1761b3b5c65d3e09fb29c743e016d5609
diff --git a/PKGBUILD b/PKGBUILD
index 4584d855a115..f92387f444a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=globalprotect-openconnect
_gitname=GlobalProtect-openconnect
-pkgver=1.2.7
+pkgver=1.2.8
pkgrel=1
pkgdesc="A GlobalProtect VPN client (GUI) for Linux based on Openconnect and built with Qt5, supports SAML auth mode."
arch=(x86_64)
@@ -11,29 +11,29 @@ license=('GPL3')
depends=('openconnect>=8.0.0' qt5-base qt5-webengine qt5-websockets)
makedepends=()
source=(
- "${_gitname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "https://github.com/itay-grudev/SingleApplication/archive/v3.0.19.tar.gz"
- "https://github.com/SergiusTheBest/plog/archive/1.1.5.tar.gz"
+ "${_gitname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "https://github.com/itay-grudev/SingleApplication/archive/v3.0.19.tar.gz"
+ "https://github.com/SergiusTheBest/plog/archive/1.1.5.tar.gz"
)
sha256sums=(
- 'dc99b46e0b0fe793273accac63cee1432008cc6717a679a05c43ee79d08584d0'
- '9405fd259288b2a862e91e5135bccee936f0438e1b32c13603277132309d15e0'
- '6c80b4701183d2415bec927e1f5ca9b1761b3b5c65d3e09fb29c743e016d5609'
+ 'b10a23f04681f14a71240272765882e56618bbf696b680e6aeebcdce7963aa24 -'
+ '9405fd259288b2a862e91e5135bccee936f0438e1b32c13603277132309d15e0'
+ '6c80b4701183d2415bec927e1f5ca9b1761b3b5c65d3e09fb29c743e016d5609'
);
prepare() {
- mv "$srcdir/SingleApplication-3.0.19" -T "$srcdir/${_gitname}-${pkgver}/singleapplication"
- mv "$srcdir/plog-1.1.5" -T "$srcdir/${_gitname}-${pkgver}/plog"
+ mv "$srcdir/SingleApplication-3.0.19" -T "$srcdir/${_gitname}-${pkgver}/singleapplication"
+ mv "$srcdir/plog-1.1.5" -T "$srcdir/${_gitname}-${pkgver}/plog"
}
build() {
- cd "$srcdir/${_gitname}-${pkgver}"
- qmake CONFIG+=release "${srcdir}/${_gitname}-${pkgver}/GlobalProtect-openconnect.pro"
- make
+ cd "$srcdir/${_gitname}-${pkgver}"
+ qmake CONFIG+=release "${srcdir}/${_gitname}-${pkgver}/GlobalProtect-openconnect.pro"
+ make
}
package() {
- cd "$srcdir/${_gitname}-${pkgver}"
- make INSTALL_ROOT="$pkgdir/" install
+ cd "$srcdir/${_gitname}-${pkgver}"
+ make INSTALL_ROOT="$pkgdir/" install
}