summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-31 20:46:14 +0300
committerorhun2020-10-31 20:46:14 +0300
commit6063ee2a5d921305387eb9ad6d4bcc9dfd07f99c (patch)
treec640c6bf4409fe71986a6f0fc69d1c9eee56318d
downloadaur-6063ee2a5d921305387eb9ad6d4bcc9dfd07f99c.tar.gz
Initial upload: globe-cli-git 0.1.1.r0.g6ef5c31-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8b8f3652f4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = globe-cli-git
+ pkgdesc = ASCII globe generator (git)
+ pkgver = 0.1.1.r0.g6ef5c31
+ pkgrel = 1
+ url = https://github.com/adamsky/globe
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ provides = globe-cli
+ conflicts = globe-cli
+ source = git+https://github.com/adamsky/globe
+ sha512sums = SKIP
+
+pkgname = globe-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ced31850ad8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=globe-cli-git
+_pkgname=globe
+pkgver=0.1.1.r0.g6ef5c31
+pkgrel=1
+pkgdesc="ASCII globe generator (git)"
+arch=('x86_64')
+url="https://github.com/adamsky/globe"
+license=('GPL3')
+makedepends=('cargo' 'git')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 "target/release/$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+}