summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:43:33 +0200
committerSanskritFritz2015-06-14 00:43:33 +0200
commit59b8c49b9aa2b1443cd583213ef2f1f1d86a7ce2 (patch)
tree74af3dba4546efa566e601b7593dd9b694be1286
downloadaur-59b8c49b9aa2b1443cd583213ef2f1f1d86a7ce2.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--globonote.desktop9
-rw-r--r--globonote.sh4
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6269588af442
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = globonote
+ pkgdesc = Create sticky notes, to-do lists, reminders and other notes in one place.
+ pkgver = 1.4.1
+ pkgrel = 2
+ url = http://globonote.info/
+ arch = any
+ license = GPLv2
+ depends = java-runtime
+ source = http://sourceforge.net/projects/globonote/files/globonote/GloboNote-1.4.1/globonote-1.4.1.tar.gz
+ source = globonote.sh
+ source = globonote.desktop
+ md5sums = ae395cfd5705c87cf26f0b24e344a3d3
+ md5sums = 6355ec8b0545e8853e3a441a7caaf200
+ md5sums = 3d72cd1aa49d00c9820033201170bd17
+
+pkgname = globonote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec12edcb85e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=globonote
+pkgver=1.4.1
+pkgrel=2
+pkgdesc="Create sticky notes, to-do lists, reminders and other notes in one place."
+arch=(any)
+url="http://globonote.info/"
+license=('GPLv2')
+depends=(java-runtime)
+source=("http://sourceforge.net/projects/globonote/files/globonote/GloboNote-$pkgver/$pkgname-$pkgver.tar.gz"
+ "$pkgname.sh" "$pkgname.desktop")
+
+package() {
+ cd "$srcdir/GloboNote"
+ mkdir --parents "$pkgdir/usr/share/java/$pkgname"
+ cp --recursive * "$pkgdir/usr/share/java/$pkgname/"
+# rm "$pkgdir/usr/share/java/$pkgname/GloboNote.exe"
+ install -Dm0755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm0644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
+md5sums=('ae395cfd5705c87cf26f0b24e344a3d3'
+ '6355ec8b0545e8853e3a441a7caaf200'
+ '3d72cd1aa49d00c9820033201170bd17')
diff --git a/globonote.desktop b/globonote.desktop
new file mode 100644
index 000000000000..722cdf24726f
--- /dev/null
+++ b/globonote.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=GloboNote
+GenericName=GloboNote
+Comment=Create sticky notes, to-do lists, reminders and other notes in one place
+Exec=/usr/bin/globonote
+Categories=Office
+Icon=/usr/share/java/globonote/doc/images/globonote16.png
diff --git a/globonote.sh b/globonote.sh
new file mode 100644
index 000000000000..eaaa68457db5
--- /dev/null
+++ b/globonote.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /usr/share/java/globonote
+"$JAVA_HOME/bin/java" -jar '/usr/share/java/globonote/GloboNote.jar'
+