summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-07-09 11:41:34 +0300
committerMantas Mikulėnas2015-07-09 11:42:09 +0300
commit37f51be2d29b257e6fa4ba847ea251809f366eec (patch)
treea36bd18652cd55da57d17a9fcb367f41c8457613
parent9571d2f95e355479fa7b0aa1956d3e1eafbe7d23 (diff)
downloadaur-37f51be2d29b257e6fa4ba847ea251809f366eec.tar.gz
move back to /opt, add a profile.d snippet
-rw-r--r--PKGBUILD9
-rw-r--r--globus.env.sh3
-rw-r--r--globus.install4
3 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee3f21b9efe7..43b189469a47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,22 +12,25 @@ provides=("globus=$pkgver")
replaces=(globus)
conflicts=(globus)
source=(http://toolkit.globus.org/ftppub/gt6/installers/src/globus_toolkit-$pkgver.tar.gz
+ globus.env.sh
globus.sysusers)
sha1sums=('2f6c451664d01d238906519ca33a4b4d9fb1217d'
+ 'ad9c17923fb85224cb134beb79c04871c3a18307'
'48e2f95145dfa27b0fee81022e33039e8524399c')
install="globus.install"
build() {
- cd globus_toolkit-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd "globus_toolkit-$pkgver"
+ ./configure --prefix=/opt/globus
make
}
package() {
- cd globus_toolkit-$pkgver
+ cd "globus_toolkit-$pkgver"
make DESTDIR="$pkgdir" install
cd "$srcdir"
+ install -Dm 644 globus.env.sh "$pkgdir/etc/profile.d/globus.sh"
install -Dm 644 globus.sysusers "$pkgdir/usr/lib/sysusers.d/globus.conf"
}
diff --git a/globus.env.sh b/globus.env.sh
new file mode 100644
index 000000000000..ef69e8422a7f
--- /dev/null
+++ b/globus.env.sh
@@ -0,0 +1,3 @@
+GLOBUS_LOCATION="/opt/globus"; export GLOBUS_LOCATION
+
+. "$GLOBUS_LOCATION/share/globus-user-env.sh"
diff --git a/globus.install b/globus.install
index 738c0771f12f..1e3c5f852392 100644
--- a/globus.install
+++ b/globus.install
@@ -1,9 +1,5 @@
post_install() {
systemd-sysusers globus.conf
-
- echo -e "To use Globus, run the following commands:\n \
- export GLOBUS_LOCATION=/opt/globus\n \
- source $GLOBUS_LOCATION/etc/globus-user-env.sh"
}
post_upgrade() {