summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-03-30 20:12:15 +0800
committerChocobo12017-03-30 20:12:15 +0800
commitd809439cdfa60a03579d444e778f64d275510a88 (patch)
treef542ee776f91a220405d7f1b6b8892d8623c31a7
downloadaur-d809439cdfa60a03579d444e778f64d275510a88.tar.gz
newpkg: glog-git 0.3.4.r88.gda816ea-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20b264a5de76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = glog-git
+ pkgdesc = C++ implementation of the Google logging module
+ pkgver = 0.3.4.r88.gda816ea
+ pkgrel = 1
+ url = https://github.com/google/glog
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ provides = glog
+ conflicts = glog
+ source = git+https://github.com/google/glog.git
+ sha256sums = SKIP
+
+pkgname = glog-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f54e967302f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=glog-git
+pkgver=0.3.4.r88.gda816ea
+pkgrel=1
+pkgdesc="C++ implementation of the Google logging module"
+arch=('i686' 'x86_64')
+url="https://github.com/google/glog"
+license=('BSD')
+makedepends=('git')
+provides=('glog')
+conflicts=('glog')
+source=('git+https://github.com/google/glog.git')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "glog"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "glog"
+
+ aclocal
+ autoconf
+ automake -a
+
+ ./configure
+ make
+}
+
+check() {
+ cd "glog"
+
+ #make check
+}
+
+package() {
+ cd "glog"
+
+ make prefix="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/glog/LICENSE"
+}
+