summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Gallouët2020-05-30 14:08:25 +0000
committerAdrien Gallouët2020-05-30 14:08:25 +0000
commit194cbda89c615ace95dfae09428345f9d2e4ce9d (patch)
treeff93ee4865a3f9de7e5604416c97fc858da2402a
parentc118862a1e980ddab8f72cfadbb11bfd8d160105 (diff)
downloadaur-194cbda89c615ace95dfae09428345f9d2e4ce9d.tar.gz
Use git+tag as source
Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa679c4716fe..bc58eb29ade4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = glorytun
pkgdesc = A small, simple and secure VPN
pkgver = 0.3.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/angt/glorytun
arch = x86_64
license = BSD
+ makedepends = git
makedepends = libsodium
makedepends = pkg-config
depends = libsodium
depends = iproute2
- source = https://github.com/angt/glorytun/releases/download/v0.3.4/glorytun-0.3.4.tar.gz
- md5sums = 17aa07b9b8440d9d9b513b5682645975
+ source = git+https://github.com/angt/glorytun#tag=v0.3.4
+ md5sums = SKIP
pkgname = glorytun
-
diff --git a/PKGBUILD b/PKGBUILD
index cc60c9ec9736..ddcb289421a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Adrien Gallouët <adrien@gallouet.fr>
pkgname=glorytun
pkgver=0.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="A small, simple and secure VPN"
arch=('x86_64')
url="https://github.com/angt/glorytun"
license=('BSD')
depends=('libsodium' 'iproute2')
-makedepends=('libsodium' 'pkg-config')
-source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('17aa07b9b8440d9d9b513b5682645975')
+makedepends=('git' 'libsodium' 'pkg-config')
+source=("git+$url#tag=v${pkgver}")
+md5sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install-strip
}