summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Gallouët2020-05-30 14:15:21 +0000
committerAdrien Gallouët2020-05-30 14:15:21 +0000
commit56200e29957972a1bf78e44767d2d725370ec0ae (patch)
treecd9d5d574ab17e434b7bd047c3bd6905d6d0b5f5
parent194cbda89c615ace95dfae09428345f9d2e4ce9d (diff)
downloadaur-56200e29957972a1bf78e44767d2d725370ec0ae.tar.gz
Add prepare()
Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddcb289421a9..7700b37a0586 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,11 @@ makedepends=('git' 'libsodium' 'pkg-config')
source=("git+$url#tag=v${pkgver}")
md5sums=('SKIP')
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
+
build() {
cd "$srcdir/$pkgname"
./autogen.sh