summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA.I2020-03-29 16:23:35 +0800
committerA.I2020-03-29 16:50:14 +0800
commitba9ce739e4ab5433a460c199066be299a660eeb0 (patch)
treef53b0851685f65e404ef6f8734eb5771976e3b30
parent3c14772912c9097504a7d5f4abe040492fab5c54 (diff)
downloadaur-ba9ce739e4ab5433a460c199066be299a660eeb0.tar.gz
prepare for batch update
-rw-r--r--PKGBUILD8
-rw-r--r--publish.sh23
2 files changed, 28 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63a7882cb2fb..4106396357e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: A.I. <merrick@luois.me>
-pkgname=glow-sans-sc-normal
+_script=PH_SCRIPT
+_width=PH_WIDTH
+pkgname=glow-sans-${_script}-${_width}
pkgver=v0.9
pkgrel=1
pkgdesc="SHSans-derived CJK font family with a more concise & modern look."
url="https://welai.github.io/glow-sans"
arch=(any)
license=(MIT)
-source=(https://github.com/welai/glow-sans/releases/download/$pkgver/GlowSansSC-Normal-$pkgver.zip)
-md5sums=("638aa86bc312c8d115169031b978250b")
+source=(https://github.com/welai/glow-sans/releases/download/$pkgver/GlowSans${_script^^}-${_width^}-$pkgver.zip)
+md5sums=('33c6941b2f82ef2b71940c0753cf8c78')
package() {
install -Dt "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 $srcdir/*.otf
diff --git a/publish.sh b/publish.sh
new file mode 100644
index 000000000000..87fbf23943b2
--- /dev/null
+++ b/publish.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/env bash
+
+scripts=(sc tc j)
+widths=(compressed condensed extended normal wide)
+
+git commit --allow-empty "update package"
+for script in "${scripts[@]}"
+do
+ for width in "${widths[@]}"
+ do
+ pkgname="glow-sans-${script}-${width}"
+ echo "updating $pkgname"
+ sed -i -e "s/PH_SCRIPT/${script}/g" PKGBUILD
+ sed -i -e "s/PH_WIDTH/${width}/g" PKGBUILD
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+ git add .
+ git commit -m "updates $pkgname"
+ git remote set-url aur "ssh://aur@aur.archlinux.org/$pkgname"
+ git push aur master
+ git reset --hard HEAD~1
+ done
+done