summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrany2020-12-30 18:07:42 +0200
committerrany2020-12-30 18:07:42 +0200
commit336d8855b1ad8968715f56a9c8b0df712766b5da (patch)
tree7886f25f727094fbbcd20ee7940854fa55e3a75f
parent8e68ea481ab2473c20c57a4185633ca6460850f3 (diff)
downloadaur-336d8855b1ad8968715f56a9c8b0df712766b5da.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
-rw-r--r--glowing-bear.desktop1
3 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3ca29e790a6..ae49879bcb8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = glowing-bear-electron-git
+pkgbase = glowing-bear-electron
pkgdesc = A web client for Weechat (Electron version)
- pkgver = 0.9.0.r65.g88a95c0
+ pkgver = 0.9.0
pkgrel = 1
url = https://www.glowing-bear.org/
arch = any
@@ -10,12 +10,11 @@ pkgbase = glowing-bear-electron-git
makedepends = npm
makedepends = git
depends = electron
- source = git+https://github.com/glowing-bear/glowing-bear.git
+ depends = glowing-bear-web
source = glowing-bear.desktop
source = glowing-bear.sh
- sha256sums = SKIP
- sha256sums = 9a8bb59b862a048442a81853b4f600783b159493a5e608a6a9fdc32ea7060777
+ sha256sums = 8e8f5c38849a8e76e0f217c38c24b5b6b297b7c644ea3513ea80a5ac39787424
sha256sums = edcfb232718f4fd54e2bd3b4cc00b6c8de6e8189feab2ec16fb64464833a09b3
-pkgname = glowing-bear-electron-git
+pkgname = glowing-bear-electron
diff --git a/PKGBUILD b/PKGBUILD
index 47e880a4b63d..4a4400856de0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,20 @@
# Maintainer: rany <rany@disroot.org>
-pkgname=glowing-bear-electron-git
-pkgver=0.9.0.r65.g88a95c0
+pkgname=glowing-bear-electron
+pkgver=0.9.0
pkgrel=1
pkgdesc="A web client for Weechat (Electron version)"
arch=(any)
url="https://www.glowing-bear.org/"
license=('GPL-3.0')
groups=(irc weechat)
-depends=(electron)
+depends=(electron glowing-bear-web)
makedepends=(npm git)
-source=("git+https://github.com/glowing-bear/glowing-bear.git"
- "glowing-bear.desktop"
+source=("glowing-bear.desktop"
"glowing-bear.sh")
-sha256sums=("SKIP"
- "9a8bb59b862a048442a81853b4f600783b159493a5e608a6a9fdc32ea7060777"
+sha256sums=("8e8f5c38849a8e76e0f217c38c24b5b6b297b7c644ea3513ea80a5ac39787424"
"edcfb232718f4fd54e2bd3b4cc00b6c8de6e8189feab2ec16fb64464833a09b3")
-prepare() {
- # Install the dependencies
- cd "glowing-bear"
- npm install
-}
-
-pkgver() {
- cd "glowing-bear"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd "glowing-bear"
- npm run build
-}
-
package() {
- # Copy the app to usr/lib/glowing-bear
- cd "glowing-bear/build"
- mkdir -p "${pkgdir}/usr/lib/glowing-bear"
- cp * -R "${pkgdir}/usr/lib/glowing-bear"
-
# Register the binary as glowing-bear
install -Dm755 "${srcdir}/glowing-bear.sh" "${pkgdir}/usr/bin/glowing-bear"
diff --git a/glowing-bear.desktop b/glowing-bear.desktop
index 3357fab4611d..4b1752b8dabe 100644
--- a/glowing-bear.desktop
+++ b/glowing-bear.desktop
@@ -13,3 +13,4 @@ Icon=glowing-bear
Type=Application
Categories=Network;Chat;IRCClient;ConsoleOnly;Internet;Communication;IRC;
MimeType=x-scheme-handler/irc;x-scheme-handler/ircs;
+StartupWMClass=Glowing Bear