summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrany2020-12-29 23:08:40 +0200
committerrany2020-12-29 23:08:40 +0200
commit94eaa4b89e6d276f039e13f579879912ee6f28a6 (patch)
treef5eea6de443ffa00b9d6e1fc0e611af6cd033c58
downloadaur-94eaa4b89e6d276f039e13f579879912ee6f28a6.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD54
-rw-r--r--glowing-bear.desktop10
-rw-r--r--glowing-bear.sh5
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6242a20c3084
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = glowing-bear-git
+ pkgdesc = A web client for Weechat (Electron version)
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://www.glowing-bear.org/
+ arch = any
+ groups = irc
+ groups = weechat
+ license = GPL-3.0
+ makedepends = npm
+ makedepends = git
+ depends = electron
+ source = git+https://github.com/glowing-bear/glowing-bear.git#tag=0.9.0
+ source = glowing-bear.desktop
+ source = glowing-bear.sh
+ sha256sums = SKIP
+ sha256sums = 0df8757eb5a0d1aca43e86d35bf99178626de0741e9d5e35b71fabd151e4a1ab
+ sha256sums = c366508cac1c450e397f26caa92f951a8afff5b78f17223781d7a775b8a4ea9c
+
+pkgname = glowing-bear-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99b1817b4c46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: rany <rany@disroot.org>
+pkgname=glowing-bear-electron-git
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="A web client for Weechat (Electron version)"
+arch=(any)
+url="https://www.glowing-bear.org/"
+license=('GPL-3.0')
+groups=(irc weechat)
+depends=(electron)
+makedepends=(npm git)
+source=("git+https://github.com/glowing-bear/glowing-bear.git"
+ "glowing-bear.desktop"
+ "glowing-bear.sh")
+sha256sums=("SKIP"
+ "0df8757eb5a0d1aca43e86d35bf99178626de0741e9d5e35b71fabd151e4a1ab"
+ "c366508cac1c450e397f26caa92f951a8afff5b78f17223781d7a775b8a4ea9c")
+
+prepare() {
+ # Install the dependencies
+ cd "glowing-bear"
+ npm install
+}
+
+pkgver() {
+ cd "glowing-bear"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "glowing-bear"
+ npm run build
+}
+
+package() {
+ # Copy the app to usr/lib/glowing-bear
+ cd "glowing-bear/build"
+ mkdir -p "${pkgdir}/usr/lib/glowing-bear"
+ cp * -R "${pkgdir}/usr/lib/glowing-bear"
+
+ # Register the binary as glowing-bear
+ install -Dm755 "${srcdir}/glowing-bear.sh" "${pkgdir}/usr/bin/glowing-bear"
+
+ # Add the scalable icon
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
+ ln -sf /usr/lib/glowing-bear/assets/img/glowing-bear.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/glowing-bear.svg"
+
+ # Add the 128x128 icon
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/128x128/apps"
+ ln -sf /usr/lib/glowing-bear/assets/img/glowing_bear_128x128.png "${pkgdir}/usr/share/icons/hicolor/128x128/apps/glowing-bear.png"
+
+ # Add the .desktop file
+ install -Dm644 "$srcdir/glowing-bear.desktop" "${pkgdir}/usr/share/applications/glowing-bear.desktop"
+}
diff --git a/glowing-bear.desktop b/glowing-bear.desktop
new file mode 100644
index 000000000000..a153dff93629
--- /dev/null
+++ b/glowing-bear.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Glowing Bear
+Comment=A web client for WeeChat
+Comment[fr]=Un client web pour Weechat
+Exec=glowing-bear
+Icon=glowing-bear
+Terminal=false
+Categories=Internet;Communication;IRC;
diff --git a/glowing-bear.sh b/glowing-bear.sh
new file mode 100644
index 000000000000..f087bbae9996
--- /dev/null
+++ b/glowing-bear.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+mkdir -p "$HOME/.config/glowing-bear"
+cd "$HOME/.config/glowing-bear"
+electron /usr/lib/glowing-bear "${@}"