summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaha6622020-07-26 10:37:43 -0400
committerhaha6622020-07-26 10:37:43 -0400
commit35dd6444917b3e707e11bc21bf8afe6ee3f4ad9e (patch)
tree666ee7cfcac37e09d20eb10ce15a4f05cbece422
downloadaur-35dd6444917b3e707e11bc21bf8afe6ee3f4ad9e.tar.gz
Initial upload: glowing-bear-web 0.9.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfb3e5ddc7ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = glowing-bear-web
+ pkgdesc = A web client for WeeChat
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/glowing-bear/glowing-bear
+ arch = any
+ license = MIT
+ source = https://github.com/glowing-bear/glowing-bear/archive/0.9.0.tar.gz
+ sha256sums = 9ff5370b4d384b1d7fff77ed5c46014cb2733f14f5032096f4acfdf6a4d0cf63
+
+pkgname = glowing-bear-web
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22d8341c21b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: haha662 <haha662 at outlook dot com>
+
+_origname=glowing-bear
+pkgname=glowing-bear-web
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="A web client for WeeChat"
+arch=("any")
+url="https://github.com/glowing-bear/glowing-bear"
+license=("MIT")
+depends=()
+# If want to host js files locally
+# makedepends=("npm" "bower" "git")
+optdepends=()
+source=("https://github.com/glowing-bear/glowing-bear/archive/${pkgver}.tar.gz")
+sha256sums=("9ff5370b4d384b1d7fff77ed5c46014cb2733f14f5032096f4acfdf6a4d0cf63")
+
+build() {
+ cd "${srcdir}"/${_origname}-${pkgver}
+
+ # If want to host js files locally
+ # npm run make-local
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/webapps/${_origname}
+ cp -R "${srcdir}"/${_origname}-${pkgver}/* "${pkgdir}"/usr/share/webapps/${_origname}
+} \ No newline at end of file