summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-12-18 09:56:56 +0800
committerChocobo12020-12-18 10:02:14 +0800
commit030743c0cebc1ee50c91940394b4cbf2ce0a711e (patch)
tree45d9783836d576337ec556e1e5ca59e59f522fdd
downloadaur-030743c0cebc1ee50c91940394b4cbf2ce0a711e.tar.gz
newpkg: glpk-git r275.g4e03800
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c75bbf0bd101
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = glpk-git
+ pkgdesc = GNU Linear Programming Kit: solve LP, MIP and other problems
+ pkgver = r275.g4e03800
+ pkgrel = 1
+ url = https://www.gnu.org/software/glpk/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ depends = gmp
+ provides = glpk
+ conflicts = glpk
+ options = staticlibs
+ source = git+https://salsa.debian.org/science-team/glpk.git
+ sha256sums = SKIP
+
+pkgname = glpk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93e77f6855d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=glpk-git
+pkgver=r275.g4e03800
+pkgrel=1
+pkgdesc="GNU Linear Programming Kit: solve LP, MIP and other problems"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/glpk/"
+license=('GPL')
+depends=('glibc' 'gmp')
+makedepends=('git')
+provides=('glpk')
+conflicts=('glpk')
+options=('staticlibs')
+source=("git+https://salsa.debian.org/science-team/glpk.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "glpk"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "glpk"
+
+ ./autogen.sh
+ ./configure \
+ --prefix="/usr" \
+ --with-gmp
+ make
+}
+
+check() {
+ cd "glpk"
+
+ make check
+}
+
+package() {
+ cd "glpk"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 doc/{glpk,gmpl}.pdf -t "$pkgdir/usr/share/doc/glpk"
+}