summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheArtist2017-01-17 13:51:06 +0200
committerTheArtist2017-01-17 13:51:06 +0200
commita62007d7d1abff603edb4b969fe9e40d7f0edf4e (patch)
tree260918f5c85d226259c3c95c8e5c550b958b24b6
downloadaur-a62007d7d1abff603edb4b969fe9e40d7f0edf4e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af8b106ac924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = glslviewer-git
+ pkgdesc = Live GLSL coding render for MacOS and Linux
+ pkgver = r314.765aed8
+ pkgrel = 1
+ url = https://github.com/patriciogonzalezvivo/glslViewer
+ arch = i686
+ arch = x86_64
+ license = BSD-3-Clause
+ makedepends = git
+ depends = glfw
+ provides = glslviewer-git
+ conflicts = glslviewer-git
+ source = glslviewer-git::git+https://github.com/patriciogonzalezvivo/glslViewer
+ md5sums = SKIP
+
+pkgname = glslviewer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..670e123c58fa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..038f00b27769
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Agorgianitis Loukas <agorglouk@gmail.com>
+pkgname=glslviewer-git
+pkgver=r314.765aed8
+pkgrel=1
+pkgdesc="Live GLSL coding render for MacOS and Linux"
+arch=('i686' 'x86_64')
+url="https://github.com/patriciogonzalezvivo/glslViewer"
+license=('BSD-3-Clause')
+depends=('glfw')
+makedepends=('git')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-VCS}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-VCS}"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 bin/glslViewer "$pkgdir/usr/local/bin/glslviewer"
+ install -D -m644 bin/glslLoader "$pkgdir/usr/local/bin/glslloader"
+}