summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheArtist2017-01-17 15:22:20 +0200
committerTheArtist2017-01-17 15:22:20 +0200
commitd624b5a5a3b32809e304e3a27513f0e1b30daeb1 (patch)
treeb837a1d877cbfe44faf0c38183c3a7b5d64bb39b
parentd219a87624baf50b10b99e25136db7cb9590b91a (diff)
downloadaur-d624b5a5a3b32809e304e3a27513f0e1b30daeb1.tar.gz
Added patch for better compatibility with floating WMs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rw-r--r--floating_wm_workaround.patch14
3 files changed, 25 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af8b106ac924..2d89ef2d6d65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,9 @@ pkgbase = glslviewer-git
provides = glslviewer-git
conflicts = glslviewer-git
source = glslviewer-git::git+https://github.com/patriciogonzalezvivo/glslViewer
+ source = floating_wm_workaround.patch
md5sums = SKIP
+ md5sums = 0d5e68722253fd33a25e57d7e2405a5c
pkgname = glslviewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 50c24cd7c3d3..c21dd5a8661b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,21 @@ depends=('glfw')
makedepends=('git')
provides=("${pkgname%-VCS}")
conflicts=("${pkgname%-VCS}")
-source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer"
+ 'floating_wm_workaround.patch')
+md5sums=('SKIP'
+ '0d5e68722253fd33a25e57d7e2405a5c')
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-VCS}"
+ patch -p1 -i "$srcdir/floating_wm_workaround.patch"
+}
+
build() {
cd "$srcdir/${pkgname%-VCS}"
make
diff --git a/floating_wm_workaround.patch b/floating_wm_workaround.patch
new file mode 100644
index 000000000000..31972a18325f
--- /dev/null
+++ b/floating_wm_workaround.patch
@@ -0,0 +1,14 @@
+diff --git a/src/app.cpp b/src/app.cpp
+index 35d06a3..3e33eb7 100644
+--- a/src/app.cpp
++++ b/src/app.cpp
+@@ -175,6 +175,9 @@ void initGL (glm::ivec4 &_viewport, bool _headless) {
+ glfwWindowHint(GLFW_VISIBLE, GLFW_FALSE);
+ }
+
++ // Make it float
++ glfwWindowHint(GLFW_RESIZABLE, GLFW_FALSE);
++
+ window = glfwCreateWindow(_viewport.z, _viewport.w, appTitle.c_str(), NULL, NULL);
+
+ if(!window) {