summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJáchym Barvínek2017-08-25 16:20:28 +0200
committerJáchym Barvínek2017-08-25 16:20:28 +0200
commitf5f7966f4bb49213254442e992d2dad2f46751ce (patch)
treeb84083c7ccd69cb7e0611c97d833aeee140ef1f4
downloadaur-f5f7966f4bb49213254442e992d2dad2f46751ce.tar.gz
gltl2ba-git initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..141dbf7ff3ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gltl2ba-git
+ pkgdesc = Enriches ltl2ba with graph generation capabilities
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/PatrickTrentin88/gltl2ba
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ depends = ltl2ba
+ depends = graphviz
+ depends = python-graphviz
+
+pkgname = gltl2ba-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d87450634f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Your Name <jachymb@gmail.com>
+pkgname=gltl2ba-git
+pkgver=1
+pkgrel=1
+pkgdesc="Enriches ltl2ba with graph generation capabilities"
+arch=('x86_64')
+url="https://github.com/PatrickTrentin88/gltl2ba"
+license=('GPLv3')
+groups=()
+depends=('ltl2ba' 'graphviz' 'python-graphviz')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=()
+noextract=()
+md5sums=()
+
+_gitroot=https://github.com/PatrickTrentin88/gltl2ba.git
+_gitname=$pkgname
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -m755 -D gltl2ba "$pkgdir/usr/bin/gltl2ba"
+}
+
+# vim:set ts=2 sw=2 et: