summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsta Zahn2021-01-01 14:58:22 -0500
committerIsta Zahn2021-01-01 14:58:22 -0500
commit035a565be0f253f28945cb20a1c4b2a834c685a6 (patch)
treecc3c814562eab574af3b9728fa7805bb48e02904
parentd35a4fe318e87d1abc185dc998ce0da9efa020c9 (diff)
downloadaur-035a565be0f253f28945cb20a1c4b2a834c685a6.tar.gz
update to version 1.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD10
2 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01ba33865657..3a6c6a02e053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glueviz
pkgdesc = Linked Data Visualizations Across Multiple Files
- pkgver = 0.14.0
+ pkgver = 1.0.0
pkgrel = 1
url = http://glueviz.org/
arch = i386
@@ -10,8 +10,22 @@ pkgbase = glueviz
depends = python
depends = python-glue-core
depends = python-glue-vispy-viewers
- source = https://files.pythonhosted.org/packages/d0/2f/4da66f6905fec451dd210cf5158db894feb02202828d12d896e112dd75d0/glueviz-0.14.0.tar.gz
- sha256sums = 8b084f94e429048074f8f2e26243c104a2ce64e2d501529e431a09fdedf66e83
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-astropy
+ depends = pyqt5
+ depends = ipython
+ depends = python-ipykernel
+ depends = python-qtconsole
+ depends = python-dill
+ depends = python-h5py
+ depends = python-xlrd
+ depends = python-mpl-scatter-density
+ depends = python-bottleneck
+ source = https://files.pythonhosted.org/packages/08/69/38d188e12ea19241355be1a212702775d0e48463d765b98d366dc6aaa63b/glueviz-1.0.0.tar.gz
+ sha256sums = 89db2b2331eb74f221251b129f6ce6b507f14101caea993ee0926ceeeaaf68ab
pkgname = glueviz
diff --git a/PKGBUILD b/PKGBUILD
index c870457abcd6..b9082f3af2bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Ista Zahn <istazahn@gmail.com>
pkgname=glueviz
-pkgver=0.14.0
+pkgver=1.0.0
pkgrel=1
pkgdesc="Linked Data Visualizations Across Multiple Files"
arch=('i386' 'x86_64')
url="http://glueviz.org/"
license=('CUSTOM')
-depends=('python' 'python-glue-core' 'python-glue-vispy-viewers')
+depends=('python' 'python-glue-core' 'python-glue-vispy-viewers' 'python-numpy' 'python-matplotlib' 'python-scipy'
+ 'python-pandas' 'python-astropy' 'pyqt5' 'ipython' 'python-ipykernel' 'python-qtconsole' 'python-dill'
+ 'python-h5py' 'python-xlrd' 'python-mpl-scatter-density' 'python-bottleneck')
makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/d0/2f/4da66f6905fec451dd210cf5158db894feb02202828d12d896e112dd75d0/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('8b084f94e429048074f8f2e26243c104a2ce64e2d501529e431a09fdedf66e83')
+source=(https://files.pythonhosted.org/packages/08/69/38d188e12ea19241355be1a212702775d0e48463d765b98d366dc6aaa63b/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('89db2b2331eb74f221251b129f6ce6b507f14101caea993ee0926ceeeaaf68ab')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"