summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsta Zahn2018-05-02 12:53:07 -0400
committerIsta Zahn2018-05-02 12:53:07 -0400
commit440b752f33479090b2f84a459e47e5f31d0ae363 (patch)
treed003b8608c492b896fed531abafe722c196e52b2
downloadaur-440b752f33479090b2f84a459e47e5f31d0ae363.tar.gz
initial rough draft
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD28
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9031fad06a1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = glueviz
+ pkgdesc = Linked Data Visualizations Across Multiple Files
+ pkgver = 0.13.2
+ pkgrel = 1
+ url = https://github.com/jorgebastida/glue
+ arch = i386
+ arch = x86_64
+ license = CUSTOM
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-pandas
+ depends = python-astropy
+ depends = python-pyqt5
+ depends = ipython
+ depends = python-ipykernel
+ depends = python-qtconsole
+ depends = python-dill
+ depends = python-h5py
+ source = https://files.pythonhosted.org/packages/a2/71/f6741c6bc70ff6a2e22a2ab3312940f4a17efcc063c03197c74212596a07/glueviz-0.13.2.tar.gz
+ sha256sums = 0a2b3a827eecd1b013427be925de4e5b15fed0fe26bf55457273f825e6b298b6
+
+pkgname = glueviz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c78823a4a943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ista Zahn <istazahn@gmail.com>
+
+pkgname=glueviz
+pkgver=0.13.2
+pkgrel=1
+pkgdesc="Linked Data Visualizations Across Multiple Files"
+arch=('i386' 'x86_64')
+url="https://github.com/jorgebastida/glue"
+license=('CUSTOM')
+depends=('python' 'python-numpy' 'python-matplotlib' 'python-pandas' 'python-astropy' 'python-pyqt5' 'ipython' 'python-ipykernel' 'python-qtconsole' 'python-dill' 'python-h5py')
+makedepends=('python-setuptools')
+source=(https://files.pythonhosted.org/packages/a2/71/f6741c6bc70ff6a2e22a2ab3312940f4a17efcc063c03197c74212596a07/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('0a2b3a827eecd1b013427be925de4e5b15fed0fe26bf55457273f825e6b298b6')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install -O1 --root="${pkgdir}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
+
+
+package(){
+ cd "${srcdir}/glue-${pkgver}"
+ python setup.py install --root="$pkgdir" --prefix=/usr
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+