summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm dragon2016-01-20 07:20:30 -0500
committerStorm dragon2016-01-20 07:20:30 -0500
commitf216597da2be12ec7c4196747e9c9de61e749a4b (patch)
treedf306bebdb095f813eb52ad3df8c46cfc41c63ab
downloadaur-f216597da2be12ec7c4196747e9c9de61e749a4b.tar.gz
Initial commit, moved from AUR 3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--gmabooster.sh33
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cd328ef4d80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Jan 20 12:20:06 UTC 2016
+pkgbase = gmabooster
+ pkgdesc = Tool to (over)clock Intel 945GM/GME/GMS/GSE, 943/940GML/GU, and GMA 950.
+ pkgver = 09c
+ pkgrel = 3
+ url = http://www.gmabooster.com/
+ arch = i686
+ license = donationware
+ source = https://github.com/ciferkey/GMABooster_Linux/raw/master/GMABooster_Linux_09c.zip
+ source = gmabooster.sh
+ md5sums = 1b5476298f531a538af746671dc51b7a
+ md5sums = a8e4fbfb1299139aa9a7f14047bc8be5
+
+pkgname = gmabooster
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddd3218729f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer Storm Dragon <stormdragon2976@gmail.com>
+# Contributer: Matthew Brunelle <ciferkey@gmail.com>
+# Contributor: Kyla McDonald <kyla.r.mcdonald@gmail.com>
+# Contributor: Chris Down <cdown.uk@gmail.com>
+# Contributor: Alexander Straube <alexander.straube@googlemail.com>
+
+pkgname=gmabooster
+pkgver=09c
+pkgrel=3
+pkgdesc="Tool to (over)clock Intel 945GM/GME/GMS/GSE, 943/940GML/GU, and GMA 950."
+arch=(i686)
+url="http://www.gmabooster.com/"
+license=('donationware')
+source=('https://github.com/ciferkey/GMABooster_Linux/raw/master/GMABooster_Linux_09c.zip'
+ 'gmabooster.sh')
+md5sums=('1b5476298f531a538af746671dc51b7a'
+ 'a8e4fbfb1299139aa9a7f14047bc8be5')
+
+build() {
+ install -D -c -m755 ${srcdir}/GMABooster ${pkgdir}/opt/GMABooster/GMABooster || return 1
+ install -D -c -m755 ${srcdir}/data.bin ${pkgdir}/opt/GMABooster/data.bin || return 2
+ install -D -c -m755 ${srcdir}/Readme_GMABooster.txt ${pkgdir}/opt/GMABooster/Readme_GMABooster.txt || return 3
+ install -D -c -m755 ${srcdir}/gmabooster.sh ${pkgdir}/usr/bin/gmabooster || return 4
+}
diff --git a/gmabooster.sh b/gmabooster.sh
new file mode 100644
index 000000000000..1b0d8568df94
--- /dev/null
+++ b/gmabooster.sh
@@ -0,0 +1,33 @@
+#!/bin/bash
+
+# Contributor: Chris Down <cdown.uk@gmail.com>
+
+# Wrapper for gmabooster to prompt that it should be run as root
+
+# We don't want to simply block root or check for the existence of su/sudo,
+# as the user might be running in a fakeroot environment, etc...
+# (and even if we aren't root, let's assume the user knows what they're doing)
+
+if [[ "${EUID}" -eq 0 ]]; then
+ /opt/GMABooster/GMABooster "$@"
+ # Store it in a variable so we can exit with the same return code
+ gbexit="$?"
+else
+ echo "GMABooster should be run as root to function properly."
+
+ while true; do
+ read -p "Do you wish to continue anyway? (y/n): " DOCONT
+ case "${DOCONT}" in
+ y|Y)
+ /opt/GMABooster/GMABooster "$@"
+ exit "$?"
+ ;;
+ n|N) exit "126" ;;
+ *) echo "Please enter y or n." ;;
+ esac
+ done
+fi
+
+# Exit with the same return code as gmabooster
+# (We shouldn't ever get down to here... but just in case)
+exit "${gbexit-127}"