summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXnopyt2019-12-12 17:07:01 +0000
committerXnopyt2019-12-12 17:07:01 +0000
commit2dce8128d5174a9264deb4cd58997c6058bb8331 (patch)
tree0cf3ce0867f5577070517b029d0efca0880eaf04
downloadaur-2dce8128d5174a9264deb4cd58997c6058bb8331.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..726c8871d237
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gmad-git
+ pkgdesc = Garry's Mod Addon Creator and Extractor
+ pkgver = v1.1
+ pkgrel = 1
+ url = https://github.com/garrynewman/gmad
+ arch = x86_64
+ makedepends = premake
+ provides = gmad
+ source = gmad::git+https://github.com/garrynewman/gmad.git#branch=master
+ source = bootil::git+https://github.com/garrynewman/bootil.git#branch=master
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = gmad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c5530e70287
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Xnopyt <billy@xnopyt.info>
+pkgname="gmad-git"
+pkgver=v1.1
+pkgrel=1
+pkgdesc="Garry's Mod Addon Creator and Extractor"
+arch=( "x86_64" )
+url="https://github.com/garrynewman/gmad"
+
+makedepends=( "premake" )
+provides=( "gmad" )
+
+source=("gmad::git+https://github.com/garrynewman/gmad.git#branch=master"
+ "bootil::git+https://github.com/garrynewman/bootil.git#branch=master")
+
+md5sums=("SKIP"
+ "SKIP")
+
+build() {
+ cd "$srcdir/bootil/projects"
+ premake4 gmake
+ cd "$srcdir/bootil/projects/linux/gmake"
+ make
+ cd "$srcdir/gmad"
+ premake4 --outdir="bin/" --bootil_lib="$srcdir/bootil/lib/linux/gmake" --bootil_inc="$srcdir/bootil/include/" gmake
+ make
+}
+
+package() {
+ install -Dm755 $srcdir/gmad/bin/gmad_linux "$pkgdir"/usr/bin/gmad
+} \ No newline at end of file