summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXnopyt2021-04-21 20:29:07 +0100
committerXnopyt2021-04-21 20:29:07 +0100
commitb4aadd107006632f8c5e4f8cbe5d3eb14296b763 (patch)
treec7acff31046df2aa368d03a426b80b690f7f2800
parent2dce8128d5174a9264deb4cd58997c6058bb8331 (diff)
downloadaur-b4aadd107006632f8c5e4f8cbe5d3eb14296b763.tar.gz
Change gmad git url to facepunch and use premake5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 726c8871d237..faf522ae7a24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = gmad-git
pkgdesc = Garry's Mod Addon Creator and Extractor
pkgver = v1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/garrynewman/gmad
arch = x86_64
makedepends = premake
provides = gmad
- source = gmad::git+https://github.com/garrynewman/gmad.git#branch=master
+ source = gmad::git+https://github.com/Facepunch/gmad.git#branch=master
source = bootil::git+https://github.com/garrynewman/bootil.git#branch=master
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2c5530e70287..03e5466e9858 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xnopyt <billy@xnopyt.info>
pkgname="gmad-git"
pkgver=v1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Garry's Mod Addon Creator and Extractor"
arch=( "x86_64" )
url="https://github.com/garrynewman/gmad"
@@ -9,7 +9,7 @@ url="https://github.com/garrynewman/gmad"
makedepends=( "premake" )
provides=( "gmad" )
-source=("gmad::git+https://github.com/garrynewman/gmad.git#branch=master"
+source=("gmad::git+https://github.com/Facepunch/gmad.git#branch=master"
"bootil::git+https://github.com/garrynewman/bootil.git#branch=master")
md5sums=("SKIP"
@@ -17,14 +17,13 @@ md5sums=("SKIP"
build() {
cd "$srcdir/bootil/projects"
- premake4 gmake
- cd "$srcdir/bootil/projects/linux/gmake"
- make
+ premake5 gmake
+ make config=release_x64
cd "$srcdir/gmad"
- premake4 --outdir="bin/" --bootil_lib="$srcdir/bootil/lib/linux/gmake" --bootil_inc="$srcdir/bootil/include/" gmake
+ premake5 --outdir="bin/" --bootil_lib="$srcdir/bootil/projects/release_x64_linux" --bootil_inc="$srcdir/bootil/include/" gmake
make
}
package() {
install -Dm755 $srcdir/gmad/bin/gmad_linux "$pkgdir"/usr/bin/gmad
-} \ No newline at end of file
+}