summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-10 13:25:53 -0700
committerMark Wagie2021-03-10 13:25:53 -0700
commitaa88fe3e4b94230e89ef289bf593ba3dbeeaac4b (patch)
treec72c4dd06f3c2786b7ca8845cdb55b51b019f3c4
parentffef876e6a649b950c540d9244ae71be87dc0c5c (diff)
downloadaur-aa88fe3e4b94230e89ef289bf593ba3dbeeaac4b.tar.gz
2.21.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd844913341a..1455423ffc54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gmail-desktop
pkgdesc = Unofficial Gmail desktop app
- pkgver = 2.21.0
+ pkgver = 2.21.2
pkgrel = 1
url = https://github.com/timche/gmail-desktop
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = gmail-desktop
depends = electron
optdepends = libnotify: desktop notifications
optdepends = libappindicator-gtk3: tray icon
- source = gmail-desktop-2.21.0.tar.gz::https://github.com/timche/gmail-desktop/archive/v2.21.0.tar.gz
+ source = gmail-desktop-2.21.2.tar.gz::https://github.com/timche/gmail-desktop/archive/2.21.2.tar.gz
source = gmail-desktop.sh
source = gmail-desktop.desktop
- sha256sums = 3daf6feff7c2ca74800cb879357a600b5538982970d142962569b4c79e72f8c0
+ sha256sums = ec2753db95697c63031dca5e66f79cd920d09f08e17b794f78a05cf13bedbcc4
sha256sums = a1f2eb9525dd10556ffde37a4dc9e06636a81d1d9ce815d1167e48954abee1dc
sha256sums = 8c30e207fe88455f63f4c0b2ae9087a2ca2bbeaa68b9be244c31a9ec392373c4
diff --git a/PKGBUILD b/PKGBUILD
index 000c35e3926d..530ceae7136c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gmail-desktop
-pkgver=2.21.0
+pkgver=2.21.2
pkgrel=1
pkgdesc="Unofficial Gmail desktop app"
arch=('x86_64')
@@ -10,10 +10,10 @@ depends=('electron')
makedepends=('yarn')
optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('3daf6feff7c2ca74800cb879357a600b5538982970d142962569b4c79e72f8c0'
+sha256sums=('ec2753db95697c63031dca5e66f79cd920d09f08e17b794f78a05cf13bedbcc4'
'a1f2eb9525dd10556ffde37a4dc9e06636a81d1d9ce815d1167e48954abee1dc'
'8c30e207fe88455f63f4c0b2ae9087a2ca2bbeaa68b9be244c31a9ec392373c4')
@@ -21,16 +21,16 @@ prepare() {
cd "$pkgname-$pkgver"
# Disable building of other packages
- sed -i '112,116d' package.json
+ sed -i '102,106d' package.json
sed -i 's/tar.bz2/dir/g' package.json
- sed -i 's/macos --linux --windows --publish never/linux --publish never/g' \
- package.json
+ sed -i 's/linux --windows/linux/g' package.json
}
build() {
cd "$pkgname-$pkgver"
yarn install --cache-folder "$srcdir/yarn-cache"
- yarn dist
+ yarn tsc
+ yarn dist:others
}
package() {