summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-10 17:34:26 -0700
committerMark Wagie2021-03-10 17:34:26 -0700
commitfa5068b611bc02f21339e5d084e2975e82792c46 (patch)
tree6e9872145bd39c889ef5ca78fbc4e1678202863d
parentaa88fe3e4b94230e89ef289bf593ba3dbeeaac4b (diff)
downloadaur-fa5068b611bc02f21339e5d084e2975e82792c46.tar.gz
2.22.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1455423ffc54..3c99382dc3b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gmail-desktop
pkgdesc = Unofficial Gmail desktop app
- pkgver = 2.21.2
+ pkgver = 2.22.0
pkgrel = 1
url = https://github.com/timche/gmail-desktop
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = gmail-desktop
depends = electron
optdepends = libnotify: desktop notifications
optdepends = libappindicator-gtk3: tray icon
- source = gmail-desktop-2.21.2.tar.gz::https://github.com/timche/gmail-desktop/archive/2.21.2.tar.gz
+ source = gmail-desktop-2.22.0.tar.gz::https://github.com/timche/gmail-desktop/archive/2.22.0.tar.gz
source = gmail-desktop.sh
source = gmail-desktop.desktop
- sha256sums = ec2753db95697c63031dca5e66f79cd920d09f08e17b794f78a05cf13bedbcc4
+ sha256sums = fdcc2cd2603c68f68e5c8f15b86918384aecd241806c42be45579cec7c4c6650
sha256sums = a1f2eb9525dd10556ffde37a4dc9e06636a81d1d9ce815d1167e48954abee1dc
sha256sums = 8c30e207fe88455f63f4c0b2ae9087a2ca2bbeaa68b9be244c31a9ec392373c4
diff --git a/PKGBUILD b/PKGBUILD
index 530ceae7136c..82c533ef8671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gmail-desktop
-pkgver=2.21.2
+pkgver=2.22.0
pkgrel=1
pkgdesc="Unofficial Gmail desktop app"
arch=('x86_64')
@@ -13,7 +13,7 @@ optdepends=('libnotify: desktop notifications'
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('ec2753db95697c63031dca5e66f79cd920d09f08e17b794f78a05cf13bedbcc4'
+sha256sums=('fdcc2cd2603c68f68e5c8f15b86918384aecd241806c42be45579cec7c4c6650'
'a1f2eb9525dd10556ffde37a4dc9e06636a81d1d9ce815d1167e48954abee1dc'
'8c30e207fe88455f63f4c0b2ae9087a2ca2bbeaa68b9be244c31a9ec392373c4')
@@ -21,16 +21,15 @@ prepare() {
cd "$pkgname-$pkgver"
# Disable building of other packages
- sed -i '102,106d' package.json
+ sed -i '107,111d' package.json
sed -i 's/tar.bz2/dir/g' package.json
- sed -i 's/linux --windows/linux/g' package.json
}
build() {
cd "$pkgname-$pkgver"
yarn install --cache-folder "$srcdir/yarn-cache"
- yarn tsc
- yarn dist:others
+ yarn compile
+ yarn build:linux
}
package() {