summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-06 15:06:59 -0700
committerMark Wagie2021-03-06 15:06:59 -0700
commitffef876e6a649b950c540d9244ae71be87dc0c5c (patch)
tree0b2a1ed0d144fa65ca6dbd7bd91f4f5f0cb77ee8
parent9b43ca34830e8fa15d594ae9cbd66acea0bd48ae (diff)
downloadaur-ffef876e6a649b950c540d9244ae71be87dc0c5c.tar.gz
actually revert to 2.21.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a12d08d849a..fd844913341a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gmail-desktop
pkgdesc = Unofficial Gmail desktop app
- pkgver = 2.21.1
- pkgrel = 2
+ pkgver = 2.21.0
+ pkgrel = 1
url = https://github.com/timche/gmail-desktop
arch = x86_64
license = MIT
@@ -9,10 +9,10 @@ pkgbase = gmail-desktop
depends = electron
optdepends = libnotify: desktop notifications
optdepends = libappindicator-gtk3: tray icon
- source = gmail-desktop-2.21.1.tar.gz::https://github.com/timche/gmail-desktop/archive/v2.21.1.tar.gz
+ source = gmail-desktop-2.21.0.tar.gz::https://github.com/timche/gmail-desktop/archive/v2.21.0.tar.gz
source = gmail-desktop.sh
source = gmail-desktop.desktop
- sha256sums = 0245b6ae9c5df72e9c1ec25493e70410e2fc50e01e7fb339c2119ecf6be49dec
+ sha256sums = 3daf6feff7c2ca74800cb879357a600b5538982970d142962569b4c79e72f8c0
sha256sums = a1f2eb9525dd10556ffde37a4dc9e06636a81d1d9ce815d1167e48954abee1dc
sha256sums = 8c30e207fe88455f63f4c0b2ae9087a2ca2bbeaa68b9be244c31a9ec392373c4
diff --git a/PKGBUILD b/PKGBUILD
index c0d5e8724a2b..000c35e3926d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gmail-desktop
-pkgver=2.21.1
-pkgrel=2
+pkgver=2.21.0
+pkgrel=1
pkgdesc="Unofficial Gmail desktop app"
arch=('x86_64')
url="https://github.com/timche/gmail-desktop"
@@ -13,7 +13,7 @@ optdepends=('libnotify: desktop notifications'
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('0245b6ae9c5df72e9c1ec25493e70410e2fc50e01e7fb339c2119ecf6be49dec'
+sha256sums=('3daf6feff7c2ca74800cb879357a600b5538982970d142962569b4c79e72f8c0'
'a1f2eb9525dd10556ffde37a4dc9e06636a81d1d9ce815d1167e48954abee1dc'
'8c30e207fe88455f63f4c0b2ae9087a2ca2bbeaa68b9be244c31a9ec392373c4')
@@ -21,15 +21,16 @@ prepare() {
cd "$pkgname-$pkgver"
# Disable building of other packages
- sed -i '101,105d' package.json
+ sed -i '112,116d' package.json
sed -i 's/tar.bz2/dir/g' package.json
- sed -i 's/linux --windows/linux/g' package.json
+ sed -i 's/macos --linux --windows --publish never/linux --publish never/g' \
+ package.json
}
build() {
cd "$pkgname-$pkgver"
yarn install --cache-folder "$srcdir/yarn-cache"
- yarn dist:others
+ yarn dist
}
package() {