summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2021-09-24 13:06:07 +0100
committergrufo2021-09-24 13:06:07 +0100
commit63bea573c1ea0dd91607605fa91f4b1b3d597240 (patch)
treec5714d09b2454e23aefef6fe4da9c4bee1f3c0b1
downloadaur-63bea573c1ea0dd91607605fa91f4b1b3d597240.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD52
-rw-r--r--gman-commands.patch22
-rw-r--r--gman.desktop10
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99496b076dc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = gman
+ pkgdesc = Small man(1) front-end for X
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = https://launchpad.net/ubuntu/impish/+package/gman
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = atk
+ depends = cairo
+ depends = fontconfig
+ depends = libxft
+ depends = gdk-pixbuf2
+ depends = gtk2
+ depends = libunwind
+ depends = mandoc
+ depends = xterm
+ depends = perl
+ optdepends = evince: for xxx
+ optdepends = gv: for xxx
+ optdepends = lighttpd: for xxx
+ optdepends = man2html: for xxx
+ optdepends = lighttpd: for xxx
+ conflicts = gman-git
+ conflicts = gman-bin
+ options = !makeflags
+ options = !buildflags
+ source = https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/gman/0.9.3-5.3build1/gman_0.9.3.orig.tar.gz
+ source = https://launchpadlibrarian.net/470122831/gman_0.9.3-5.3build1.debian.tar.xz
+ source = gman-commands.patch
+ source = gman.desktop
+ sha256sums = 27d11b4f2d41691335cb666ca07e6b491fb24496b30330ffbbb26eaa24ed0f99
+ sha256sums = 63f895facd009a44820fd3bc45fc0e9319c2c32812d93d0a423ed5ca203b8f08
+ sha256sums = 77f37734f5496f0f070a84871474177f1de6ca338cf1e9472b9f882ab161a819
+ sha256sums = 479d105ceb6d24b01d82e2792b7aac022b8e918489bd770b26ec612060edc5b4
+
+pkgname = gman
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cb6b26ed301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+
+pkgname='gman'
+pkgver='0.9.3'
+pkgrel=1
+pkgdesc='Small man(1) front-end for X'
+arch=('i686' 'x86_64')
+url="https://launchpad.net/ubuntu/impish/+package/${pkgname}"
+license=('GPL')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
+depends=('atk' 'cairo' 'fontconfig' 'libxft' 'gdk-pixbuf2' 'gtk2' 'libunwind'
+ 'mandoc' 'xterm' 'perl')
+optdepends=('evince: for xxx'
+ 'gv: for xxx'
+ 'lighttpd: for xxx'
+ 'man2html: for xxx'
+ 'lighttpd: for xxx')
+source=("https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/${pkgname}/${pkgver}-5.3build1/${pkgname}_${pkgver}.orig.tar.gz"
+ "https://launchpadlibrarian.net/470122831/${pkgname}_${pkgver}-5.3build1.debian.tar.xz"
+ 'gman-commands.patch'
+ 'gman.desktop')
+options=('!makeflags' '!buildflags')
+sha256sums=('27d11b4f2d41691335cb666ca07e6b491fb24496b30330ffbbb26eaa24ed0f99'
+ '63f895facd009a44820fd3bc45fc0e9319c2c32812d93d0a423ed5ca203b8f08'
+ '77f37734f5496f0f070a84871474177f1de6ca338cf1e9472b9f882ab161a819'
+ '479d105ceb6d24b01d82e2792b7aac022b8e918489bd770b26ec612060edc5b4')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch < "${srcdir}/debian/patches/pre-${pkgver}-5.1.patch"
+ patch < "${srcdir}/gman-commands.patch"
+ patch < "${srcdir}/debian/patches/sensible-browser.patch"
+ patch < "${srcdir}/debian/patches/evince.patch"
+ patch < "${srcdir}/debian/patches/manpath.patch"
+ patch < "${srcdir}/debian/patches/gnome-terminal.patch"
+ patch < "${srcdir}/debian/patches/fix-ftbfs-with-binutils-gold.patch"
+ patch < "${srcdir}/debian/patches/0007-test.c-Let-main-function-return-int-to-fix-FTBFS.patch"
+ patch < "${srcdir}/debian/patches/0008-Makefile-Take-DESTDIR-into-consideration.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/gman.desktop" "${pkgdir}/usr/share/applications/gman.desktop"
+}
+
diff --git a/gman-commands.patch b/gman-commands.patch
new file mode 100644
index 000000000000..b3b94ed0852e
--- /dev/null
+++ b/gman-commands.patch
@@ -0,0 +1,22 @@
+--- a/mandata.c 2002-05-21 07:39:34.000000000 +0100
++++ b/mandata.c 2021-09-24 12:28:11.179118333 +0100
+@@ -316,7 +316,7 @@
+ strcat(buffer,loc_name);
+ strcat(buffer," ; ");
+ strcat(buffer,(char*)context->get_value("browser_command"));
+- //if (strstr((char*)context->get_value("browser_command"),"mozilla")) strcat(buffer," -chrome ");
++ if (strstr((char*)context->get_value("browser_command"),"mozilla")) strcat(buffer," -chrome ");
+ strcat(buffer,loc_name);
+ strcat(buffer," ; sleep 120; rm ");
+ strcat(buffer,loc_name);
+--- a/gman.c 2021-09-24 12:54:13.464903000 +0100
++++ b/gman.c 2021-09-24 12:59:31.346113598 +0100
+@@ -89,7 +89,7 @@
+ context->set_default_value("show_status_bar","int",(void*)0);
+ context->set_default_value("show_warning","int",(void*)0);
+ context->set_default_value("show_mode","int",(void*)0); // 0 = xterm, 1 = ghostview
+- context->set_default_value("xterm_command","char*",(void*)"x-terminal-emulator");
++ context->set_default_value("xterm_command","char*",(void*)"xterm");
+ context->set_default_value("gv_command","char*",(void*)"gv");
+ context->set_default_value("evince_command","char*",(void*)"evince");
+ context->set_default_value("browser_command","char*",(void*)"sensible-browser"); // kfm also works
diff --git a/gman.desktop b/gman.desktop
new file mode 100644
index 000000000000..6b30cf86d968
--- /dev/null
+++ b/gman.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=GMan
+GenericName=Small man(1) front-end for X
+Comment=Manual pages
+Exec=gman
+Icon=help
+Categories=System;
+X-GNOME-UsesNotifications=true