summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-11-13 13:02:39 +1100
committerStephen Gregoratto2019-11-13 13:02:39 +1100
commit3ade289eccf56dd826eb075c51059629b741dc6f (patch)
tree3bcf3eb1dcf8b73ccce215c92e348dc81339a5ac
downloadaur-3ade289eccf56dd826eb075c51059629b741dc6f.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59e1725f7a76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gmenu
+ pkgdesc = desktop application launcher
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://git.sr.ht/~tslocum/gmenu
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = go-pie
+ makedepends = gtk3
+ source = https://git.sr.ht/~tslocum/gmenu/archive/v0.2.3.tar.gz
+ sha256sums = 6f2ff530a8aa664bf835d84607396bab12509e6c2dd38e78f525b9a6215a068e
+
+pkgname = gmenu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb37585ae863
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stephen Gregoratto <dev at sgregoratto dot me>
+pkgname=gmenu
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="desktop application launcher"
+url="https://git.sr.ht/~tslocum/gmenu"
+license=('MIT')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+makedepends=('go-pie' 'gtk3')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('6f2ff530a8aa664bf835d84607396bab12509e6c2dd38e78f525b9a6215a068e')
+
+build() {
+ cd "$pkgname-v$pkgver"
+ for cmd in "gmenu" "gtkmenu"; do
+ go build \
+ -trimpath \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ -v -o "gmenu" ./cmd/$cmd
+ done
+}
+
+package() {
+ install -Dm755 "$pkgname-v$pkgver/gmenu" "$pkgdir/usr/bin/gmenu"
+ install -Dm755 "$pkgname-v$pkgver/gtkmenu" "$pkgdir/usr/bin/gtkmenu"
+ install -Dm755 "$pkgname-v$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}