summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2021-10-16 10:11:49 +0200
committerAndrea Feletto2021-10-16 10:11:49 +0200
commit1067f4a07f618d14192d2a8c3295fccdd9aef4ad (patch)
tree2bc6722aeef80478cd2047c0bc5e06141fce20d4
parentaf840e1bda3e079d00df4a8abf84be8c42a9dd25 (diff)
downloadaur-1067f4a07f618d14192d2a8c3295fccdd9aef4ad.tar.gz
download tarball instead of individual files
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2711ef62f8c0..427ce6537717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gmid-bin
pkgdesc = Fast Gemini server written with security in mind.
pkgver = 1.7.5
- pkgrel = 1
+ pkgrel = 2
url = https://gmid.omarpolo.com
arch = x86_64
license = ISC
@@ -9,13 +9,9 @@ pkgbase = gmid-bin
provides = gmid
conflicts = gmid
conflicts = gmid-git
- source = https://github.com/omar-polo/gmid/releases/download/1.7.5/gmid.linux.amd64
- source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.5/gmid.1
+ source = https://github.com/omar-polo/gmid/releases/download/1.7.5/gmid-1.7.5-binaries.tar.gz
source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.5/LICENSE
- source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.5/README.md
- sha256sums = b9b5fd01503f9f053e08de3fe38deeffa19c4770e2ae975bb2b9ea58a4a78629
- sha256sums = 4950287661a3ee2970e337f18ad769821633b73799438d15a0aa90a9775700cd
+ sha256sums = 97009f8acdc81c1202dd14dfdcaea8e3fd99983ff1e0e4711258d3e75f49ecdc
sha256sums = f82c1fa80d35427d109a77ed59ecda41474ef46539238750876702fa40579f9f
- sha256sums = 425308363e30b4fa0d2fdd321d20070816ce856fe55c8a4654ebd1fd3ad7a23f
pkgname = gmid-bin
diff --git a/PKGBUILD b/PKGBUILD
index e6dbbb2098db..a633e7b49519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gmid-bin
_pkgname=${pkgname%-*}
pkgver=1.7.5
-pkgrel=1
+pkgrel=2
pkgdesc='Fast Gemini server written with security in mind.'
arch=('x86_64')
url='https://gmid.omarpolo.com'
@@ -13,22 +13,20 @@ provides=('gmid')
conflicts=('gmid' 'gmid-git')
depends=('libretls')
source=(
- "https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname.linux.amd64"
- "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/gmid.1"
+ "https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver-binaries.tar.gz"
"https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/LICENSE"
- "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/README.md"
)
sha256sums=(
- 'b9b5fd01503f9f053e08de3fe38deeffa19c4770e2ae975bb2b9ea58a4a78629'
- '4950287661a3ee2970e337f18ad769821633b73799438d15a0aa90a9775700cd'
+ '97009f8acdc81c1202dd14dfdcaea8e3fd99983ff1e0e4711258d3e75f49ecdc'
'f82c1fa80d35427d109a77ed59ecda41474ef46539238750876702fa40579f9f'
- '425308363e30b4fa0d2fdd321d20070816ce856fe55c8a4654ebd1fd3ad7a23f'
)
package() {
cd "$srcdir"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+
+ cd "$_pkgname-$pkgver-binaries"
install -Dm755 "$_pkgname.linux.amd64" "$pkgdir/usr/bin/$_pkgname"
install -Dm644 gmid.1 -t "$pkgdir/usr/share/man/man1"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
}