summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-20 20:39:34 -0400
committeréclairevoyant2023-05-20 20:39:34 -0400
commita125bcbf427ff22b8a2c2acaafdadbc252b75a84 (patch)
tree40b7aef834ada21dbc9716898244e04cb6fe64b0
parent6a6bf68a6a941da600f1496433bda77c4fcfbeeb (diff)
downloadaur-gmime.tar.gz
gnvim-git: revert to v2; add gitignore and minor cleanup; bump epoch
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD52
3 files changed, 36 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52832bb83568..7c56208dce81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = gmime
- pkgdesc = A C/C++ MIME creation and parser library with support for S/MIME, PGP, and Unix mbox spools
+ pkgdesc = C/C++ MIME creation and parser library (v2) for S/MIME, PGP, and Unix mbox spools
pkgver = 2.6.23+4+g91dcee38
- pkgrel = 3
+ pkgrel = 1
+ epoch = 1
url = https://github.com/jstedfast/gmime
arch = x86_64
license = GPL
@@ -16,7 +17,7 @@ pkgbase = gmime
depends = zlib
source = git+https://github.com/jstedfast/gmime#commit=91dcee38ea301463fb9c6bc936f08b9fd1c0969f
source = 0001-Avoid-non-UTF-8-code.patch
- sha256sums = SKIP
- sha256sums = 516e339e92e419f5744abfd9b7608816115cca103727755994356b0984edcb10
+ b2sums = SKIP
+ b2sums = 29b3b3620ac2f5945f55bb96add829a843b63e79422df4b36f8964b9bd8c86ca2d41224142be06845221cb57fc8c87d0aeed34baefb7b83ade7e8dde8d8c9811
pkgname = gmime
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f22369eac57a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
+!/0001-Avoid-non-UTF-8-code.patch
diff --git a/PKGBUILD b/PKGBUILD
index b25105dd1259..47245ee31852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,52 @@
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Contributor: Ben <ben@benmazer.net>
+# Maintainer: éclairevoyant
+# Contributor: Jan de Groot <jgc at archlinux dot org>
+# Contributor: Ben <ben at benmazer dot net>
pkgname=gmime
pkgver=2.6.23+4+g91dcee38
-pkgrel=3
-pkgdesc="A C/C++ MIME creation and parser library with support for S/MIME, PGP, and Unix mbox spools"
+pkgrel=1
+epoch=1
+pkgdesc="C/C++ MIME creation and parser library (v2) for S/MIME, PGP, and Unix mbox spools"
arch=(x86_64)
license=(GPL)
-url="https://github.com/jstedfast/gmime"
+url="https://github.com/jstedfast/$pkgname"
depends=(glib2 gpgme zlib)
makedepends=(gtk-sharp-2 gobject-introspection gtk-doc git vala docbook-utils)
_commit=91dcee38ea301463fb9c6bc936f08b9fd1c0969f # gmime-2-6
source=("git+https://github.com/jstedfast/gmime#commit=$_commit"
0001-Avoid-non-UTF-8-code.patch)
-sha256sums=('SKIP'
- '516e339e92e419f5744abfd9b7608816115cca103727755994356b0984edcb10')
+b2sums=('SKIP'
+ '29b3b3620ac2f5945f55bb96add829a843b63e79422df4b36f8964b9bd8c86ca2d41224142be06845221cb57fc8c87d0aeed34baefb7b83ade7e8dde8d8c9811')
pkgver() {
- cd gmime
- git describe --tags | sed 's/-/+/g'
+ git -C $pkgname describe --tags | sed 's/-/+/g'
}
prepare() {
- cd gmime
- patch -Np1 -i ../0001-Avoid-non-UTF-8-code.patch
- NOCONFIGURE=1 ./autogen.sh
+ cd $pkgname
+ patch -Np1 -i ../0001-Avoid-non-UTF-8-code.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- # get rid of the .wapi errors in fakeroot
- mkdir weird
- export MONO_SHARED_DIR="$PWD/weird"
+ # get rid of the .wapi errors in fakeroot
+ mkdir weird
+ export MONO_SHARED_DIR="$PWD/weird"
- cd gmime
+ cd $pkgname
- ./configure --prefix=/usr \
- --program-prefix=$pkgname \
- --enable-gtk-doc \
- --enable-mono \
- --enable-smime \
- --disable-static
+ ./configure --prefix=/usr \
+ --program-prefix=$pkgname \
+ --enable-gtk-doc \
+ --enable-mono \
+ --enable-smime \
+ --disable-static
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ make
}
package() {
- cd gmime
- make DESTDIR="$pkgdir" install
+ make -C $pkgname DESTDIR="$pkgdir" install
}