summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheunpleasantowl2018-08-19 21:17:53 -0400
committertheunpleasantowl2018-08-19 21:17:53 -0400
commit147e2ee69f54f6a650fadf28f2f98e22df013e79 (patch)
tree4c8fb237212dc2ab3bf499a2a590dfa3a6cd6f7a
parent86fb2f40137deda12f75f94c22932b1b12ae258b (diff)
downloadaur-147e2ee69f54f6a650fadf28f2f98e22df013e79.tar.gz
Stage for AUR
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD40
2 files changed, 16 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f4f7820d1fb..c1966c4c6902 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = gmines.app
pkgdesc = A clone of the well-known minesweeper game.
pkgver = 0.2
- pkgrel = 3
+ pkgrel = 1
url = http://www.nongnu.org/gap/gmines/index.html
arch = i686
arch = x86_64
- groups = gnustep
+ groups = gnustep-games
license = GPL
makedepends = gcc-objc
makedepends = gnustep-make
depends = gnustep-base
depends = gnustep-gui
+ depends = gnustep-back
source = http://savannah.nongnu.org/download/gap/GMines-0.2.tar.gz
sha256sums = a7100c9846b548ef2d27c35b80370b30769dca3ac8eeff5f15a227474843c067
diff --git a/PKGBUILD b/PKGBUILD
index 7e81171a8e4f..b2319032c1cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,27 @@
-# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
-# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
pkgname=gmines.app
_pkgname=GMines
-pkgrel=3
+pkgrel=1
pkgver=0.2
pkgdesc="A clone of the well-known minesweeper game."
arch=('i686' 'x86_64')
url="http://www.nongnu.org/gap/gmines/index.html"
license=('GPL')
-groups=('gnustep')
-depends=('gnustep-base'
- 'gnustep-gui')
-makedepends=('gcc-objc'
- 'gnustep-make')
-source=("http://savannah.nongnu.org/download/gap/$_pkgname-$pkgver.tar.gz")
+groups=('gnustep-games')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://savannah.nongnu.org/download/gap/GMines-0.2.tar.gz")
sha256sums=('a7100c9846b548ef2d27c35b80370b30769dca3ac8eeff5f15a227474843c067')
build() {
- cd "$_pkgname-$pkgver"
+ cd $_pkgname-$pkgver
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
package() {
- cd "$_pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
-}
-
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file