summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfossdd2024-04-03 17:08:22 +0000
committerfossdd2024-04-03 17:08:22 +0000
commit71b2aded15a92830c13c55a20c4c6e6d9c1fb46c (patch)
treec328fbe247e0f1bea1225d2a8e107428bcef366b
downloadaur-71b2aded15a92830c13c55a20c4c6e6d9c1fb46c.tar.gz
upgpkg: gmobile-git 0.1.0.r5.7d55bed-1
upstream release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83174a5fd751
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gmobile-git
+ pkgdesc = Functions useful in mobile related, glib based projects
+ pkgver = 0.1.0.r5.7d55bed
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/Phosh/gmobile
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = git
+ makedepends = meson
+ depends = glib2
+ depends = json-glib
+ provides = gmobile
+ conflicts = gmobile
+ source = git+https://gitlab.gnome.org/World/Phosh/gmobile.git
+ md5sums = SKIP
+
+pkgname = gmobile-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df6bc2487eab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: fossdd <fossdd@pwned.life>
+pkgname=gmobile-git
+_pkgname=gmobile
+pkgver=0.1.0.r5.7d55bed
+pkgrel=1
+pkgdesc="Functions useful in mobile related, glib based projects"
+arch=('x86_64')
+url="https://gitlab.gnome.org/World/Phosh/gmobile"
+license=('GPL-3.0')
+depends=('glib2' 'json-glib')
+makedepends=('git' 'meson')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g' | sed 's/^v//')"
+}
+
+build() {
+ arch-meson $_pkgname _build
+ meson compile -C _build
+}
+
+check() {
+ meson test -C _build
+}
+
+package() {
+ meson install -C _build --destdir "$pkgdir"
+}