summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Elkin2023-12-18 03:32:44 -0500
committerDoug Elkin2023-12-18 03:32:44 -0500
commitda1554f0006480cbe125bba5e8fd6aede951757a (patch)
treea3ea996a5b93843c4a1bb694391584d4e22dbf6b
downloadaur-da1554f0006480cbe125bba5e8fd6aede951757a.tar.gz
first commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83b9f54ff4c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gmocli
+ pkgdesc = command-line interface for searching emoji characters with associated gitmoji descriptions
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/duhdugg/gmocli
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = gmocli-1.0.0.tar.gz::https://static.crates.io/crates/gmocli/gmocli-1.0.0.crate
+ sha256sums = 6c8033e90dc3d0b7a5d725da7c9d1ac9c3a397e744eb050398450af063d54409
+
+pkgname = gmocli
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f71724a68f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Doug Elkin <aur@dougelkin.com>
+
+pkgname=gmocli
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="command-line interface for searching emoji characters with associated gitmoji descriptions"
+url='https://github.com/duhdugg/gmocli'
+license=('MIT')
+arch=(x86_64)
+depends=()
+optdepends=()
+makedepends=(cargo)
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+sha256sums=('6c8033e90dc3d0b7a5d725da7c9d1ac9c3a397e744eb050398450af063d54409')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm0755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm0644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm0644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 "data/emoji/unicode-license.txt" "$pkgdir/usr/share/licenses/$pkgname/thirdparty/unicode-license.txt"
+ install -Dm0644 "data/gitmoji/gitmoji-license.txt" "$pkgdir/usr/share/licenses/$pkgname/thirdparty/gitmoji-license.txt"
+}