summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-08-08 18:20:23 +0300
committerMantas Mikulėnas2015-08-08 18:20:23 +0300
commitd681cc4114bf9bff85bba0671cd107d58701929f (patch)
treede06eb9aef8015f537ebb163113053ab87dc8d1d
downloadaur-d681cc4114bf9bff85bba0671cd107d58701929f.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3eeb7d408c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gmp-mpbsd
+ pkgdesc = BSD multi-precision arithmetic compatibility libraries from GMP
+ pkgver = 5.0.5
+ pkgrel = 1
+ url = http://gmplib.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = gcc-libs
+ depends = sh
+ provides = bsd-mp
+ options = !libtool
+ source = ftp://ftp.gmplib.org/pub/gmp-5.0.5/gmp-5.0.5.tar.xz
+ source = ftp://ftp.gmplib.org/pub/gmp-5.0.5/gmp-5.0.5.tar.xz.sig
+ sha256sums = e87015a825a2445e169931ee27849d52576a2d9e338d1383dcb36fed68d0006f
+ sha256sums = SKIP
+
+pkgname = gmp-mpbsd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d1a9ad6a650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mantas Mikulėnas <grawity@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gmp-mpbsd
+# 5.0.5 was the last version to have mpbsd
+pkgver=5.0.5
+pkgrel=1
+pkgdesc="BSD multi-precision arithmetic compatibility libraries from GMP"
+arch=('i686' 'x86_64')
+url="http://gmplib.org/"
+depends=('gcc-libs' 'sh')
+provides=('bsd-mp')
+license=('LGPL3')
+options=(!libtool)
+source=(ftp://ftp.gmplib.org/pub/gmp-$pkgver/gmp-$pkgver.tar.xz{,.sig})
+sha256sums=('e87015a825a2445e169931ee27849d52576a2d9e338d1383dcb36fed68d0006f'
+ 'SKIP')
+validpgpkeys=('73D46C3667461E4BD93972495D6D47DFDB899F46')
+
+build() {
+ cd "gmp-$pkgver"
+ if [[ $CARCH == i686 ]]; then
+ export ABI=32
+ fi
+ ./configure --build=$CHOST --prefix=/usr --enable-mpbsd
+ make
+}
+
+check() {
+ cd "gmp-$pkgver"
+ make check
+}
+
+package() {
+ cd "gmp-$pkgver"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "$pkgdir/usr/include/gmp.h" \
+ "$pkgdir/usr/lib/libgmp."* \
+ "$pkgdir/usr/share"
+}
+
+# vim: ts=2:sw=2:et: