summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-06-13 13:43:06 +0300
committerSpyros Stathopoulos2015-06-13 13:43:06 +0300
commit3758ce35708923667241ebdc5211a874557fd631 (patch)
tree9a7c8bc7fdd253ae0a29ee612c1b9e22eb8ee2ca
downloadaur-3758ce35708923667241ebdc5211a874557fd631.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD25
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2bf3ad7a681
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gmpc-lyricwiki
+ pkgdesc = A new plugin that uses the REST api of lyricwiki to fetch lyrics.
+ pkgver = 11.8.16
+ pkgrel = 4
+ url = http://gmpc.wikia.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = libmpd>=0.20.0
+ depends = libxml2
+ depends = gmpc>=11.8.16
+ source = http://download.sarine.nl/Programs/gmpc/11.8.16/gmpc-lyricwiki-11.8.16.tar.gz
+ md5sums = a5738460c41ab8ed39db7afccd5a19b0
+
+pkgname = gmpc-lyricwiki
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..74c035d4a357
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/*
+src/*
+*.tar.gz
+*.tar.xz
+*.tar.bz2
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b71be28631a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Modified from original gmpc pkgbuild created by tobias <tobias@archlinux.org>
+# Contributor: Lukas Miczka <lukascpu@gmail.com>
+
+pkgname=gmpc-lyricwiki
+pkgver=11.8.16
+pkgrel=4
+pkgdesc="A new plugin that uses the REST api of lyricwiki to fetch lyrics."
+arch=(i686 x86_64)
+url="http://gmpc.wikia.com/"
+license="GPL"
+depends=('libmpd>=0.20.0' 'libxml2' 'gmpc>=11.8.16')
+makedepends=('intltool')
+source=(http://download.sarine.nl/Programs/gmpc/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('a5738460c41ab8ed39db7afccd5a19b0')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
+}