summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWillem Mulder2017-01-16 14:55:19 +0100
committerWillem Mulder2017-01-16 14:55:19 +0100
commitc0251e3477e0ce45a5b54d4dd5e3c235483092db (patch)
treef47efbd4e6d9d471a4abb5223707d0bbee01e970
downloadaur-c0251e3477e0ce45a5b54d4dd5e3c235483092db.tar.gz
Initial package
-rw-r--r--.SRCINFO19
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD27
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b297459658bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jan 16 13:54:43 UTC 2017
+pkgbase = gmpc-mserver
+ pkgdesc = Stream music files to your mpd that are not in your database.
+ pkgver = 0.20.0
+ pkgrel = 1
+ url = http://gmpc.wikia.com/wiki/GMPC_PLUGIN_MSERVER
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ depends = gmpc>=0.15.4.102
+ depends = taglib
+ depends = libmicrohttpd
+ source = http://download.sarine.nl/Programs/gmpc/0.20.0/gmpc-mserver-0.20.0.tar.gz
+ sha256sums = dfc4872f1258a10819eec3f99562637b77fd745fb2a5cbdaf88c2c3e4e107052
+
+pkgname = gmpc-mserver
+
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..08c7cb3413a1
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+.SRCINFO -whitespace
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d2b754add8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitattributes
+!.gitignore
+!/*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13fba917fe51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+
+# Maintainer: Bjoern Franke <bjo@nord-west.org>
+# Contributor: tobias <tobias@archlinux.org>
+# Contributor: Lukas Miczka <lukascpu@gmail.com>
+
+pkgname=gmpc-mserver
+pkgver=0.20.0
+pkgrel=1
+pkgdesc="Stream music files to your mpd that are not in your database."
+arch=(i686 x86_64)
+url="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_MSERVER"
+license=("GPL2")
+depends=('gmpc>=0.15.4.102' 'taglib' 'libmicrohttpd')
+makedepends=('intltool')
+source=(http://download.sarine.nl/Programs/gmpc/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('dfc4872f1258a10819eec3f99562637b77fd745fb2a5cbdaf88c2c3e4e107052')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make CFLAGS="${CFLAGS} -DHAVE_STRNDUP"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}