summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmeGa2015-07-08 03:23:56 -0500
committerOmeGa2015-07-08 03:23:56 -0500
commit79afe12179f3771b08e633296b26577534863871 (patch)
tree1f4c0ea99d0d6776a939a87be7cdc99c54604393
downloadaur-79afe12179f3771b08e633296b26577534863871.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5238d47eff83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gmpc-wikipedia
+ pkgdesc = The Wikipedia plugin shows information about the current artist.
+ pkgver = 11.8.16
+ pkgrel = 2
+ url = http://gmpc.wikia.com/wiki/GMPC_PLUGIN_WIKIPEDIA
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = gmpc>=11.8.16
+ depends = libwebkit
+ options = !libtool
+ source = http://download.sarine.nl/Programs/gmpc/11.8.16/gmpc-wikipedia-11.8.16.tar.gz
+ sha1sums = c860e7c5614362f8cd8bf3cff820032cb1a41691
+
+pkgname = gmpc-wikipedia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14c337544943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
+# Contributor: Lukas Miczka <lukascpu@gmail.com>
+
+pkgname=gmpc-wikipedia
+pkgver=11.8.16
+pkgrel=2
+pkgdesc="The Wikipedia plugin shows information about the current artist."
+arch=('i686' 'x86_64')
+url="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_WIKIPEDIA"
+license=('GPL')
+depends=('gmpc>=11.8.16' 'libwebkit')
+makedepends=('intltool')
+options=('!libtool')
+source=(http://download.sarine.nl/Programs/gmpc/$pkgver/$pkgname-$pkgver.tar.gz)
+sha1sums=('c860e7c5614362f8cd8bf3cff820032cb1a41691')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: