summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-03-02 14:31:45 +0800
committerChocobo12018-03-02 15:57:24 +0800
commit16a53ea9d77af33be013d5afe9e75701b5ab73db (patch)
treeb453b83e1c4ebbecc145904762349014eda99a36
downloadaur-16a53ea9d77af33be013d5afe9e75701b5ab73db.tar.gz
newpkg: gmssl 2.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39fd1fcc3b0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gmssl
+ pkgdesc = Chinese national cryptographic algorithms and protocols
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://gmssl.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = perl
+ conflicts = openssl
+ options = staticlibs
+ source = https://github.com/guanzhi/GmSSL/archive/gmssl-2.0.tar.gz
+ source = ca-dir.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/ca-dir.patch?h=packages/openssl
+ sha256sums = 3e3cf33bb81a30a9d5f896cd3b381bbfbf4d989f4fcb0872d0e6dfbe92a6e632
+ sha256sums = SKIP
+
+pkgname = gmssl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d8b4ce1a1e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gmssl
+pkgver=2.0
+pkgrel=1
+pkgdesc="Chinese national cryptographic algorithms and protocols"
+arch=('i686' 'x86_64')
+url="http://gmssl.org/"
+license=('custom')
+depends=('perl')
+conflicts=('openssl')
+options=('staticlibs')
+source=("https://github.com/guanzhi/GmSSL/archive/gmssl-$pkgver.tar.gz"
+ "ca-dir.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/ca-dir.patch?h=packages/openssl")
+sha256sums=('3e3cf33bb81a30a9d5f896cd3b381bbfbf4d989f4fcb0872d0e6dfbe92a6e632'
+ 'SKIP')
+
+
+prepare() {
+ cd "GmSSL-$pkgname-$pkgver"
+
+ patch -Np0 -i "$srcdir/ca-dir.patch"
+}
+
+build() {
+ cd "GmSSL-$pkgname-$pkgver"
+
+ ./config --prefix="/usr" --openssldir="/etc/ssl" --libdir="lib"
+ make
+}
+
+check() {
+ cd "GmSSL-$pkgname-$pkgver"
+
+ #make test
+}
+
+package() {
+ cd "GmSSL-$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" MANSUFFIX="ssl" install_sw install_ssldirs install_man_docs
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}