summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:41:24 +0200
committergraziano.giuliani2015-07-04 16:41:24 +0200
commit1db0a89469e327b87ede902d144e03ebf3887c80 (patch)
tree967e378ce7e55d244d0af34ad94bf0f54346176a
downloadaur-1db0a89469e327b87ede902d144e03ebf3887c80.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--gmt.install23
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36f3561c6795
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gmt
+ pkgdesc = Generic Mapping Tools: Collection of tools for manipulating geographic and Cartesian data sets, and generating EPS maps.
+ pkgver = 5.1.2
+ pkgrel = 1
+ url = http://gmt.soest.hawaii.edu/
+ install = gmt.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = gdal
+ depends = fftw
+ optdepends = ghostscript
+ optdepends = python-sphynx
+ optdepends = python2-sphynx
+ optdepends = gmt-coast
+ optdepends = gmt-dcw
+ conflicts = gmt4
+ source = ftp://ftp.soest.hawaii.edu/gmt/gmt-5.1.2-src.tar.bz2
+ md5sums = 66212f2f237843a448fa9c0ec6cfb86d
+
+pkgname = gmt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8dd0b3ff9f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Benjamin Sick
+
+pkgname=gmt
+pkgver=5.1.2
+pkgrel=1
+pkgdesc="Generic Mapping Tools: Collection of tools for manipulating geographic and Cartesian data sets, and generating EPS maps."
+arch=(i686 x86_64)
+url="http://gmt.soest.hawaii.edu/"
+license=('GPL')
+makedepends=('cmake')
+depends=('gdal' 'fftw')
+optdepends=('ghostscript' 'python-sphynx' 'python2-sphynx' 'gmt-coast' 'gmt-dcw')
+conflicts=('gmt4')
+install=gmt.install
+source=(ftp://ftp.soest.hawaii.edu/gmt/${pkgname}-${pkgver}-src.tar.bz2)
+md5sums=('66212f2f237843a448fa9c0ec6cfb86d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ rm -fr build
+ mkdir build && cd build
+ # -DLICENSE_RESTRICTED=off \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGSHHG_ROOT=/usr/share/gmt/coast \
+ -DGMT_LIBDIR=lib \
+ -DDCW_ROOT=/usr/share/gmt/dcw \
+ -DGMT_DATADIR=share/gmt \
+ -DGMT_MANDIR=share/man \
+ -DGMT_DOCDIR=share/doc/gmt \
+ -DCMAKE_BUILD_TYPE=Release ..
+ export MAKEFLAGS="-j1"
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make DESTDIR=${pkgdir} install || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gmt.install b/gmt.install
new file mode 100644
index 000000000000..4d2ce1d30ce2
--- /dev/null
+++ b/gmt.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "==> GMT HIGH RESOLUTION AND DCW DATASETS"
+ echo ""
+ echo "==> The default installation of GMT contains a low resolution coastline dataset."
+ echo "==> For maps at higer resolutions please install the gmt-coast package."
+ echo "==> For the digital chart of the world dataset install the gmt-dcw package."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*