summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:41:32 +0200
committergraziano.giuliani2015-07-04 16:41:32 +0200
commit57139ea65c18a0063e74ba53af364f6ad9ab64a3 (patch)
tree8e2b5cc2fb4410a55c06c66221ca5f9b45989816
downloadaur-57139ea65c18a0063e74ba53af364f6ad9ab64a3.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--gmt-cpt-city.install23
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d553fdbb0b38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gmt-cpt-city
+ pkgdesc = GMT color palettes (*.cpt) from the cpt-city collection
+ pkgver = 2.15
+ pkgrel = 1
+ url = http://soliton.vm.bytemark.co.uk/pub/cpt-city
+ install = gmt-cpt-city.install
+ arch = any
+ license = GPL
+ license = APACHE
+ license = CCPL
+ license = custom
+ optdepends = gmt: the Generic Mapping Tools
+ options = !strip
+ source = http://soliton.vm.bytemark.co.uk/pub/cpt-city/pkg/cpt-city_2.15-1.tar.gz
+ md5sums = 778640246fe15dd68bc801f59c1f354b
+
+pkgname = gmt-cpt-city
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d77ea508003
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: abenson <adrian.m.benson@gmail.com>
+# vim: ts=4 et sw=4 sts=4
+
+pkgname=gmt-cpt-city
+pkgver=2.15
+_pkgsubver=1
+pkgrel=1
+pkgdesc="GMT color palettes (*.cpt) from the cpt-city collection"
+arch=('any')
+url="http://soliton.vm.bytemark.co.uk/pub/cpt-city"
+license=('GPL' 'APACHE' 'CCPL' 'custom')
+optdepends=('gmt: the Generic Mapping Tools')
+source=(http://soliton.vm.bytemark.co.uk/pub/cpt-city/pkg/cpt-city_${pkgver}-${_pkgsubver}.tar.gz)
+install=$pkgname.install
+options=('!strip') #nothing to strip, takes ages trying
+md5sums=('778640246fe15dd68bc801f59c1f354b')
+
+build() {
+ cd "$srcdir"/cpt-city-${pkgver}
+ ./configure --prefix="$pkgdir"/usr --mandir="$pkgdir"/usr/share/man
+}
+
+package() {
+ cd "$srcdir"/cpt-city-${pkgver}
+ make install
+ mkdir -p "$pkgdir"/usr/share/licenses
+ mv "$pkgdir"/usr/share/doc/cpt-city/copying "$pkgdir"/usr/share/licenses/$pkgname
+ rm -rf "$pkgdir"/usr/share/doc
+
+ #create symlink in gmt dir
+ mkdir -p "$pkgdir"/usr/share/gmt/cpt "$pkgdir"/opt/gmt5/share/cpt/cpt-city
+ # link for use with GMT5
+ # ln -s /usr/share/cpt-city "$pkgdir"/opt/gmt5/share/cpt/cpt-city
+ # link for use with GMT4
+ ln -s ../../cpt-city "$pkgdir"/usr/share/gmt/cpt/GMT_cpt-city
+}
diff --git a/gmt-cpt-city.install b/gmt-cpt-city.install
new file mode 100644
index 000000000000..6e89dcc451a8
--- /dev/null
+++ b/gmt-cpt-city.install
@@ -0,0 +1,23 @@
+
+post_install() {
+cat << EOF
+>>>
+>>> This package provides the entire Cpt-City color
+>>> palette collection.
+>>>
+>>> For usage with GMT look at:
+>>>
+>>> man cpt-city
+>>>
+>>> For examples and previews of all palettes, see the cpt-city
+>>> website at:
+>>>
+>>> http://soliton.vm.bytemark.co.uk/pub/cpt-city/
+>>>
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
+