summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-01-16 09:00:45 +0330
committerMohammadreza Abdollahzadeh2022-01-16 09:00:45 +0330
commit6697d687277490f1f9f5b42253e1dc6ae2507c06 (patch)
tree9c0913fd22b235d8d06b2768b4d228516abfbac2
parent7da5a6eb0170073913c6266999322f0839f6c29c (diff)
downloadaur-6697d687277490f1f9f5b42253e1dc6ae2507c06.tar.gz
update to v2.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aacfe5aa2c1..b1aa265e66da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = gmt-dcw
pkgdesc = The Digital Chart of the World Polygon data for the Generic Mapping Tools.
- pkgver = 2.0.2
+ pkgver = 2.1.0
pkgrel = 1
- url = https://www.generic-mapping-tools.org/
+ url = https://github.com/GenericMappingTools/dcw-gmt
arch = any
license = LGPL
- source = https://github.com/GenericMappingTools/dcw-gmt/releases/download/2.0.2/dcw-gmt-2.0.2.tar.gz
- sha256sums = 2b300f01ca350db17aadd0260ae33bf36dc6b61be4150e66829033cec3d65c3c
+ depends = gmt>=6.1.1
+ source = https://github.com/GenericMappingTools/dcw-gmt/releases/download/2.1.0/dcw-gmt-2.1.0.tar.gz
+ sha256sums = e810567cd474d5af9d84751938acb447a8612391ed66190d60d789974a1f9e29
pkgname = gmt-dcw
diff --git a/PKGBUILD b/PKGBUILD
index baa593aa8aa9..0d0170584d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=gmt-dcw
-pkgver=2.0.2
+pkgver=2.1.0
pkgrel=1
pkgdesc="The Digital Chart of the World Polygon data for the Generic Mapping Tools."
arch=('any')
-url="https://www.generic-mapping-tools.org/"
+url="https://github.com/GenericMappingTools/dcw-gmt"
license=('LGPL')
-source=("https://github.com/GenericMappingTools/dcw-gmt/releases/download/${pkgver}/dcw-gmt-${pkgver}.tar.gz")
-sha256sums=('2b300f01ca350db17aadd0260ae33bf36dc6b61be4150e66829033cec3d65c3c')
+depends=('gmt>=6.1.1')
+source=("${url}/releases/download/${pkgver}/dcw-gmt-${pkgver}.tar.gz")
+sha256sums=('e810567cd474d5af9d84751938acb447a8612391ed66190d60d789974a1f9e29')
package() {
- mkdir -p ${pkgdir}/usr/share/gmt/dcw
- install -m 644 dcw-gmt-${pkgver}/* ${pkgdir}/usr/share/gmt/dcw/
+ install -d "${pkgdir}/usr/share/gmt/dcw"
+ install -m 644 "dcw-gmt-${pkgver}"/* "${pkgdir}/usr/share/gmt/dcw/"
}
-# vim:set ts=4 sw=4:
+# vim:set ts=4 sw=4 et: